Sony HAP-Z1ES file transfer BROKEN!!!

Hello all:

I just has an enlightening/depressing discussion with a senior level Sony ES Tech.  I had not used my HAP-Z1ES recently (or more correctly I had not uploaded any music to the unit for several months).  I have done some listening, tho.

Last evening I tried to transfer some FLAC files, and the HAP did not even appear as a network device on either my Mac Pro, or Windows 10 PC.   I futzed around with it for several hours with no success.  Then I did a Google search, and found that others had gotten it to work AFTER going into the HAP hidden SMB setup screen, and selecting SMB 1.0 as the protocol.

I finally got it to work on the Windows side, but then noticed the transfer speed was half of what it used to be- and that previous speed was glacially slow. They will have to come up with a new word to describe how slow it is now.

Sony tech told me that Apple, in their infinite wisdom, rendered the SMB protocol inoperative in High Sierra onward, due to "security concerns"  Sony Japan asked Apple to come up with a workaround to allow their HAP customers to be able to continue to use their players, but was told "Not only NO, but Hell, NO. We're not the slightest bit interested"  Thanks SO much, Apple!!!!

Windows users have also been affected because Microsoft recently downgraded to SMB protocol from Ver.2 back to ver.1.  Hence, the transfer speed was cut exactly in half, and that's precisely what I observed.

The Tech told me that to continue to use a Mac to work with my HAP-Z1ES, I'd have to find an older MAC that was running an earlier version of OS-X where the SMB was not hobbled.

I'm thinking about getting a laptop and installing LINUX to see if the file transfer to the HAP would speed up- since Sony natively uses the Linux EXT4 filesystem.

Has anyone else done this?

And thanks again, Apple and Microsoft!!!

P.S.  Sony has not put any of this information on their HAP-Z1ES website- tech said their legal beagles won't let them- so the customers have to do the digging to get to the truth of what is transpiring.


kind regards,

Greg Davis


Well, that really sucks for us HAP users.  Thats what I hate about Sony, they come out with a good player and then hardly ever update the software and pretty much abandon their customers.  They did the same with SACD!  I have been asking them to add Roon or Tidal but they stick with Spotify which is MP3 quality at best.  I'm annoyed as I have 2 of these Sony players, one in each system.  There will be no more Sony purchases for me.

Unfortunately, this is what happens when you try to integrate audio systems with computers.  You're at the mercy of several large corporation who are constantly "upgrading" operating systems.  Both large and small companies have a hard time keeping up with compatibility issues.  Fortunately, an older iMac with an older OS X can be had for less than $100.

To be fair, it's not Sony's fault. Not that they could not have added a Firewire/USB3/HDMI/USB-C/Thunderbolt port to move files outside the network framework. Would have been worlds faster, and left the network side out of it.

There are many things Sony could do better.  Their tech support is atrocious, and they create new (and innovative) formats, then let them die on the vine. I own several ES components, and like them quite a bit. I have a top-end ES Minidisc deck (~$1500) that recently died after no more than 100 hours of play time. Parts no longer available to fix it. I also have an el cheapo Sony minidisc deck that was bottom of the line, but still chugging happily along like gangbusters. So go figure.

I agree about the Roon and Tidal. Should be a piece of cake to implement either. I'll have to say, though, that Sony has made quite a few functional upgrades to the Z1ES. That has probably been their most supported model as in the last few years.

Fortunately, I have an older Mac Mini laying around so hopefully I can kluge it together to move some music onto the Z1ES.



Not trying to be a smart aleck, but this is just one example of why I never jumped on board the computer audio train.  I like simple solutions that I can trust.

Thanks for sharing and sorry to hear about your situation.

That is why computers don't belong in the listening room. Too much aggravation.

It's really not that different than many of the things that can go wrong in audio except it involves very large corporations and the turnover is faster paced.  At different times for different products replacement tubes, CD mechanisms, loudspeaker drives and integrated chips are simply not available.  Try getting a replacement video controller board for a 10 year old flat screen TV.  Think of it as a semi-permanent supply chain problem.

As much a pain in the ass as it has morphed into, the Sony HAP has permanently changed the way I listen to music. I love the vinyl process, but it can be time-consuming. If I want to listen for just a bit, I can fire up the HAP, use my iPad to select music (usually from a playlist), and chill for a half hour or so with my fave tracks.

I don't like it, but I can live with inventing workarounds to keep it going.  Again, not particularly Sony's fault. If Apple/Microsoft are SO concerned about my security, they can devote more time inventing operating systems without so many vulnerabilities. 

My .02¢



I'm using my Sony HAP-Z1ES from Ubuntu. This is the mount command that made it work. It's using version 3.0.

sudo mount -t cifs -o vers=3.0,uid=1000,gid=1000,password= //<YOUR IP HERE>/HAP_Internal /mnt/haps

I have no idea what you mean, what is Ubuntu?  The Sony HAP is. Linux based system.  

He is talking about directly accessing the internal storage of the HAP with the operating systems own capabilities, instead of using a dedicated software. In the past I was able to use this to keep my HAP in sync with my local storage of FLAC files. My system was down for some years and I now tried to re-setup. But the CIFS mount does not work at the moment. Also, when I did it in the year 2017 maybe, I did not use "vers=3.0" as option. EDIT: After updating my system (over the network) I now am able to access it.

I have been using the cut and pate process with my win 10 laptop. 

I execute the HAP and then do an "explore HAP" and navigate to where I want to paste the folder of the new rips.

I do this on the wifi network but could connect an ethernet cable too.  

So far no issues in slowdown.  

The task itself is simple - we are basically copying files from one hard drive to another and it works well for me- and I export uncompressed FLAC files ! 

I just tried a copy and it is very slow.  over an hour for 436 MB.  however i did not reset router and modem which usually helps.  

i will have to try it again later.  

Update to above posts-

Reset modem and router and now file transfers are running as fast as ever. Win 10 laptop on WiFi network.  

Once again- 

Launch the HAP app. 

Find the HAP icon in the system tray, right click and execute "Explore HAP"

Navigate to your music folder.

Open your local copy of your music file folder- 

Find the new music folder.  

Copy the local folder, paste into the HAP folder. 

You can always brew install samba and use smb up to mount it.... i have this problem with printers, remember namp brew samba and smbup solve it

I have 2 HAPZ1ES players, one in each system.  I am still amazed that 10 years later, I have no desire to change to something else.  They still sound excellent.  The unit in my office system is left on all the time as it has problems turning back on if it is shut off.  I bought that one second hand for under a grand so it doesn’t bother me.  The other unit which I purchased new has been flawless.  I don’t have any problems transferring files with Windows 11.  I don’t even bother with the Sony software.  I just open Windows explorer and drag and drop, easy Peezy. 

I have not messed with Windows 11 as yet to see if the transfer rate is better/faster than Win10.  I may go the Ubuntu route to see how that works out.

I almost pulled the trigger on a second HAP-Z1ES, but ended up getting a killer deal on another Logitech Transporter, so went that route instead.  Still sounds very good, but definitely not state of the art.



The trick with Samba is to make sure it's version 3, or sometimes calls 'cifs'. Just about any system can direct mount it that way.

Ubuntu is a distribution or flavor of Linux. Technically I use PopOS, which is a stripped down Ubuntu.

I did try to use the program 'unison' to mirror the collection across to the HAPS. That was a horrible failure as the response time on the mount is too slow. The CPU is really under powered.

Ran into the EXACT same issue.  Hadn't uploaded new music for a couple years. Decided to download a couple HD Tracks albums and then rip two CDs. The two CDs took For Ev Er to transfer and then it erred. Same thing with the HD flies.  Busted out a disc drive and see if I can shoot them directly into the HAP, which I've never had luck with that process.  I get it set to transfer and head to the store/dinner. Four hours later,  it had attempted to transfer two tracks, neither worked,  and it showed 15000+ errors. What a stupid program.  Great device,  garbage software. 


I was going to break out my 15 year old laptop with Win 7 to see if that would do the trick but first,  I tried @stereo5 's method of file explorer drag-and-drop. What took HAP Transfer 6 hours to unsuccessfully complete was successfully completed in less than 30 minutes.  Thank you for saving my sanity!