New Parasound blows fuse?


Advise please.
Anyone experienced this.
Just received a new Parasound Halo integrated. Voltage was correct. We have good power in Singapore.

Connected power cable
Turned on main switch (front not turned on yet)
Loud cracker sound
Removed fuse
Fuse completely shattered
Fuse rating was correct

Cleaned up the connector
Parasound had the foresight to supply a spare fuse
Dealer says to try again with new fuse.
Should I try again or call the dealer?
Should I ask for a new unit?
I am afraid to try it. Its brand new. Not even a little sound from it yet, except the blowing of the fuse.

Could the speakers cause this? Note that the front panel switch was not turned on yet. The fuse blew before that that was done.

Very very broken hearted. Was waiting in mega anticipation to hear the music.

Pls advise.
0082de0a 09de 4362 abf8 a92d41db266cjagjag
Triple check connections. 

Unhook everything and turn it on by itself.  If the fuse blows, send it back.  If not, turn off and then hook items up one at a time.
No big deal, just replace the fuse and try again as mofimadness suggested.
Retry the fuse.


It’s quite possible the fuse you started with was damaged in transit. Second one blows, unplug it and have it serviced.

Best,
E
Thank you all. 

Called the dealer. They came down and rechecked ; the unit was dead. New fuse did not work. Could not power up.

They came with their showroom set. Swopped it and it worked fine. They will replace the unit this week. It is a holiday today. Chinese New Year. And, yet they came. Double Kudos to XAudio Singapore.

The Parasound Hint 6 and ATC SCM40 worked well. The ATC dealer used wire jumpers for the speaker. Same as the speaker cable wire. They supplied the cables. 

Overall, the system was what I had hoped for. Smiling from ear to ear. 

Cheers t'y'all and happy Chinese New Year .


Glad you got it straightened out.   Happy New Year!
The dealer should have left you the demo unit until new one arrives. Poor customer service.
Called the dealer. They came down and rechecked ; the unit was dead. New fuse did not work. Could not power up.

They came with their showroom set. Swopped it and it worked fine. They will replace the unit this week. It is a holiday today. Chinese New Year. And, yet they came. Double Kudos to XAudio Singapore.

The Parasound Hint 6 and ATC SCM40 worked well. The ATC dealer used wire jumpers for the speaker. Same as the speaker cable wire. They supplied the cables.

Overall, the system was what I had hoped for. Smiling from ear to ear.

Cheers t'y'all and happy Chinese New Year .

Now that's good customer service. Good for them good for you.

Cheers George
This sounds about right.  The crackling sound was likely something shorting inside like a bad capacitor.  When it shorted, the unit pulled more AC power than normal and the fuse blew (which it is supposed to do).  Replacing the fuse didn't do anything because the unit was already dead from shorted or burned out circuits.  This is likely one of those rare manufacturing defects.
Man, the ATC's are as tight as a ...  a.....new pair of jean's four sizes too small.