No sound and red power light on NAD C372

I haven't talked to my dealer or NAD yet about this problem, but I wanted to check if anyone has had a similar issue with their NAD or could identify what's wrong. I usually leave the C372 powered up and on standby, but after powering down and unplugging the unit for a couple of days when I wasn't around, I powered it up again to find that it provides no sound from any source, into speakers or headphones. The power light glows its warning red, but I've checked all of the potential issues in the manual (speaker cable shorts, overheating, speakers selected, tape monitor not selected, etc.) and all of that's been OK. I powered it down, disconnected, checked, and reconnected everything, powered it up again and still the same thing. I've done this numerous times, tried different sources, and so forth. This happened once before, a few weeks ago, but when I powered down and up again it was fine. Any suggestions?

The amp is only a month old, and I'm using it with Vandersteen 2ce Signature IIs and Sennheiser HD 600s, with a Marantz changer, Playstation 1, and Technics TT as sources. Cabling is Tributaries and Monster. I've been very pleased with the amp and with my system's sound as a whole, and I've also owned other NAD integrateds (302, C325BEE) in the past without incident. Thanks for any input!
I'm not familiar with NAD but from your symptoms I would guess a problem with the power supply. You may have lost a voltage. Have you tried disconnecting EVERYTHING and powering it on with the volume all the way down? Does it come up normal? If not it should be under warranty. Remember manufacturers do not design and manufacture all componets and any 1 part is prone to failure. Its really not a question of if will ever break but when. Working with electronics for over 30 years I can say most failures occur within 90 days with new equiptment. IF it goes beyond that I personally feel pretty confident. Its a bummer that its new and it has a problem. I know because I bought a new Meridian G08 that had an intermitten transport/drive.
My c320bee did the same thing. Push one by the source selection buttons such as cd.
Similar problem. Also able to resolve by checking source buttons.
Thanks for the responses. I have tried each of my sources, so the source selection isn't the issue, and I've disconnected and reconnected everything and powered up again a couple of times. It comes up just the same: speaker and source selections show as normal, but the power LED is red. I even opened it up last night to check the fuse, and it looked fine.

I'm guessing you're right, Xti16, that it's a power supply issue of some sort. My last concern is that I powered the whole system up via my APC H10 power conditioner (switches for all gear were on, with the conditioner as a master switch). Is it possible that the conditioner overloaded the amp with a surge? The APC supposed to keep the voltage constant, so it would surprise me--and also I've never had this problem with other amps, powering up the same way. Any further input much appreciated. Thanks.
Check if speaker a or b is engaged. Also , does it have jumpers in back of unit connecting pre i and pre out? Good luck. Also make sure tape monitor button isnt over riding input button.
Thanks, Wscottbellah, but I have checked the speaker selection, tape monitor, and jumpers, too. Nothing had changed except for powering the unit down and up again, and it doesn't play through headphones either. According to the manual, if the light shows red when it turns on, there's a short in the speaker cables, but I've checked that up and down, too. Still no sound. Thanks for puzzling this out with me.

I sure you checked your fuse, another thing is your unit still connected to the power conditioner? If it is, you might want to disconnect the unit and plug it directly into an outlet, and see if that solves the problem. As the problem might be with the power conditioner. If that's not the problem and seeing that you seem to have done everything else, I would contact NAD and have them check the unit since it's under warrenty.
You lost your signal to your outputs, which indicates that a signal path is open.
the problem can be twofold:
1. lost one of your voltage supplies that biases your component in the signal path.

2. defective component in your signal path. When you had the same problem but you managed to have it work indicates that the component was starting to break down at the point and now has completely broke down.
Pound on the various area of the case top and bottom and if you managed to bring back the signal, then you have a cold solder joint. But I suspect that your component is bad.
If you lost your signal to both your outputs, That would be another problem, probably a mechanical problem. (switches)

either way, Best for you to send your instrument back for diagnostic by the company. I dont think there is anything you can do to bring it back. Like Xti said, most components die the first 90 days, after 90 days, you can have confidence that your system will last a long time.
This thread was a million years ago, but I thought I'd post a follow-up just in case anybody looking at buying a C372 or other NAD amp reads it. Turns out that, ahem, I had a short in my speaker cables (bare-wire terminations gone wrong).

To restore karmic balance in the universe, I hereby admit that the problem was solely due to user error. To NAD's credit, they took the unit in for review, found nothing wrong with it, and sent it back to me with a clean bill of health--at which time I discovered the problem was on my end. The thing's worked perfectly since.

Whew. I feel better.