Cartridge Tacking Problems - Help please

I have major tonearm/cartridge tracking problems that seems to have gotten worse, leading me to believe there's a problem with the arm. Can anyone suggest what I can/should try to further diagnose the problem?

Here's what it's doing:
On some (becoming many) discs, the cartridge will just skip out of the track, as though there's a scratch, or someone bumped the stand. Changing the anti-skate setting (ie over driving the anti-skate to 2.5) helps a little, but doesn't cure it.

Here's the set-up:
Pink Triangle original table
Audioquest PT6 arm
Signet TK7SU cartridge with new stylus
(the the problem exists also with the old one)
I have no damping fluid in the trough at present

Here's what I've done:
Table is leveled and set up properly
Arm/Cartridge is set up and aligned (and quadruple-checked)
Tracking force is set at 1.75 g, which is the max recommended by Signet. I've always tracked this cartridge at 1.25 g on my old table and it worked beautifully.

thanks in advance!
I have the same tonearm on a VPI. I suggest adjusting the vertical tracking angle using the allen screw on the side of the mounting bracket near the plinth. Lower the arm so the bottom plane of the cartridge is very slightly lower in the rear than in the front or if you can see the diamond as it is glued to the cantilever, start with a parallel position and gradually move the tonearm pillar down.
Compliance matching because you are using a new arm checked? Cartridge rubber boot suspension okay? Stylus still optimum?
Did you balance the arm to zero before you set the tracking force? Did you check the tracking force independently with a stylus pressure gauge?

Compliance mis-match to effective tonearm mass is not IMO the problem here. And even if it were, it should produce some arm resonance but not that kind of mis-tracking.
Just some thoughts. Are you using an external scale to set VTF or relying on the tonearm scale if there is one)? Have you taken the arm lightly in hand and swung it over the record to see if you can detect any points where there is less than free motion? Have you tried using damping fluid (I realize it may be hard to remove)? Is this a new arm (for you) and did the problem exist with an earlier arm? I agree it sounds like a tonearm problem. Good luck, Dave
Thanks, I set the VTF force multiple times alternating between using a Shure tracking force guage, and also using the built in scale (which I also calibrated with the Shure).

I'm not sure what cartrige rubber boot suspension is. The cartrige is from the late 1970's, but I've had and used it since new, and it's always been pampered. The stylus is brand new, but when I noticed the issue I replaced the old stylus and got the same results.

I am going to purchased and install damping fuid, but wasn't convinced that would solve this severe of a problem. One thing I read about after posting this is cleaning out old damping fluid. Since the arm was shipped I assume the damping fluid may have spilled out of the trough into the bearing cavity . . perhaps that's causing a problem?

As for swinging the arm to check freedom of motion, none that I detect, but I'm not sure I'm doing this right. I swung it across while it's on the cueing support, and it seems to be fine. I'll try it again today with the arem at zero balance.

This arm is new to me, it came with the table that I purchased recently. The cartridge was previously mounted on my old Yamaha table with the "S" arm, never a problem with tracking at 1.25 g.

I'll be swapping cartriges today . . . will see if this solves it. I'm just not optimistic.

If I have an arm problem . . . are Tonearms "refurbishable"? Who would do this kind of work?

thanks again, everyone.
Bd -- you may be right about the horizontal bearing being sluggish. Possibly from spilled silicon damping fluid like you said, or maybe just dried out lubricant. Test the horizontal swing at zero VTF and NOT on the cuing support. Use a stylus guard to protect the stylus.

Another thing to check is that the tonearm connecting wires are not inhibiting the arm movement. There's tons of info about the PT6 including upgrades. Just go to Google and type "Audioquest PT6" in the search field.
One more idea. I don't know the PT6, but if the lead out phono cable attaches directly to the arm, check to insure that the cable isn't binding the table's suspension. To check, simply lift the cable as a record plays. If the platter moves, you've got a problem.

good luck.
Check to make sure the cueing support platform had cleared all the way under the arm. The arm might be hitting this. These can usually be raised or lowered.
This may be a little obvious but it did happen to me. Om an Sme 309 ,which is "fatter" at the pivot end, I lowered the arm to adjust VTA. It skipped/jumped on some discs because they had slight warps and the warp hit the arm as it neared the end of a disc!Duh!
I've never seen acompliance mis match so sever it cause the cartidge to skip, mistrack yes but not skip.
If it's not the above I would have to concour with other poters that it is a mechanical bind of some sort. Hope this helps
Than again if deicated to keeping rig and happy with it in the main maybe swapping arm out to I dunno,...maybe ubiquitous RB300 by Rega.I only say this because my buddy has had problems with his VPI 19 PT6 and every time he thinks he's gotten it solved it end s up invariable wiith worse problems.,Ask here and sat\ylum genral oppinions on reliablity of AQ arms
Your cartridge is 25+ years old. Sounds like it might be time for a new cartridge! The suspension elements of a phono cartridge will not last forever, as the rubber suspension parts will decay. This can occur even if the cartridge has not been used very heavily.

Also, do you have a sturdy table stand, and have you changed the TT stand recently?
thanks everyone . . . there are a number of suggestions I need to followup on here. I'll be out of town this week so they's need to wait til next weekend.

I have given thought to a new arm, not sure if the RB300 is my first choice or not. There are a few things that appeal to me about the PT6, so I want to try and make it work.

thanks again, I'll post results after the next tear down.
thanks Fatparrot . . . interesting point, on which I'm a little ignorant, but I thought the suspension is in the stylus assemble (which is brand new). At least as I look at mine, the only moving parts are in the stylus asm. Am I way off on this?

In any event the new cartridge is on the way and will be tried out this weekend and tell me the answer.

I do have a sturdy table stand, so I think I've ruled that out.

thanks again.
Update - the problem is solved. It turns out that the horizontal bearing was binding up, and I'm pretty sure it was from damping fluid contamination. I mounted up my new cartridge this morning and the problem had become worse than ever. It wouldn't track at all, so it seems the silicon was becoming more caked on as time went by.

I cleaned the silicon residue out of the bearing cavity as well as I could with paper towel, and then sprayed the bearing with Deoxit to de-gunk and lube the bearing. Before this procedure the binding was noticeable (ie I could feel it in my hand as I moved the arm). Now, it's tracking fine, and sounds lovely. The Grado Sonata is great, and it seems now I can sit back and listen to music on this table rather than constantly tweaking it.

Thanks to everyone!!
improper antiskating force can sometimes cause mistracking. You may have to set it by eye.
Now, crank that puppy up! Glad you fixed the seems that my advice was worth exactly what you paid for it...NOTHING :-)