Gremlins Emerge with Switch to Windows 7

I have had generally good PC audio experiences using Windows XP.

In fact, I have viewed with skepticism a lot of the PC optimization threads as I found with USB into external DACs it was pretty straightforward to get pretty darn good sound.

So I am dismayed tonight to have finally purchased a new, and much faster laptop which operates with Windows 7.

In an A/B comparison with my old laptop, using the same USB cable into my desktop system, the new laptop sounds HORRIBLE.

Can anyone please offer a simple, lean and mean configuration in Windows 7 for exporting audio via USB?

Thank you,
CW, what makes you conclude that Windows 7 has anything to do with the problem? Not saying that it doesn't, but for meaningful suggestions to be offered I think that question has to be addressed.

You indicated that the new laptop is "much faster." Depending on the jitter rejection capabilities of your DAC, if any, it seems to me that high on the list of possible causes would be increased jitter caused by increased levels of digital noise generated by the new laptop. Faster digital circuits can be expected to cause increased amounts of digital noise, everything else being equal. Other conceivable possibilities are rfi effects or ground noise effects that may bypass the usb interface altogether.

One thing I'd try, if you haven't already, would be to see if running the computer on its battery, with the ac adapter disconnected, helps at all.

Also, what differences exist between the new configuration and the old one, aside from the laptops being different. Are you playing back the same files from the same external drive, for example? Are you using the same software program for playback?

Also, can you tell us the make and model of both laptops?

Finally, can you characterize the "horrible" sound more specifically?

Best regards,
-- Al

Thank you and I know you are very good on this topic.

I will do more testing, but for starters, I just turned on Pandora, which I use with a Pandora One subscription for higher resolution.

And yes, I did immediately unplug the AC adapter, wondering if the battery alone might improve things but it did not.

The "upgrade" was nothing exotic - only to a Lenovo X201 which has a faster 1.66 chip and 8gb of memory, compared to my Lenovo S10 netbook which has an Intel Atom and only 1 gb of memory.

The only obvious difference is Windows 7 and hence my suspicion. As for settings on the computer, thats what I need to figure out.

I did not immediately recognize the audio settings compared to XP where you basically just select the USB audio device you want to use and off you go.

The sound was distorted and also had repeated tics or pops - a skipping sound.

Thanks for any ideas.
Why not KEEP your old PC just for music?
Makes sense to me.
Ever think that they skimped on the audio card? I know that new HP's that is a real problem. I've got a massively fast HP but the sound is crap compared to an older unit. I ended buying an external DAC. The internal is so bad that I don't even want to listen with headphones.
CW -- Ok, that does sound like something that is settings related.

I recall seeing a number of reports of similar symptoms with USB audio under Windows 7, which, depending on the specific computer, were resolved by disabling certain power saving features. Modern processors and motherboards have features which dynamically vary both cpu speed and cpu voltage depending on how busy the cpu is. Apparently that switching can sometimes introduce glitches into audio that is being sent out via usb, depending on the specific computer's hardware design.

Try going to Start/Control Panel/Hardware & Sound/Power Options, and selecting "High Performance."

Also, next to where it says "High Performance," go to "Change Plan Settings" and then "Change Advanced Power Settings." Expand the + sign next to "Processor Power Management," and under that expand the + signs next to "Minimum Processor State" and "Maximum Processor State." Set them both to 100% if they are not presently set that way.

If that doesn't help, you can restore the original default settings on the page that appeared after you clicked "Change Plan Settings."

There are probably also some power saving features that can be enabled or disabled in the computer's bios. As you may realize, the bios is entered at startup, before Windows starts to load, by pressing some keyboard key that is probably specified in the computer's manual.

Hope that helps,
-- Al

I like to have everything on one machine, and as a frequent participant in the forums, you should know that "audiophiles" often have a compulsion to buy and configure new hardware whether or not an older device works properly.

In addition, my netbook has been on for 8-16 hours a day for about two years, and dropped in the driveway a couple of times when rushing to work. So overdue for a new machine.

Elevick, yes, I don't even think about internal sound cards - all my audio goes out via USB into my Behringer DEQ2496 and/or an Audio Research DAC 5 at the moment. For headphones, I use a NuForce DAC which sounds pretty good.

As Al points out, however, there are still settings to configure the audio which can affect the sound.

Al - thanks and I will also check the system and power usage settings.

At the moment, the Sound shortcut can see that my playback device is "SPDIF Interface" which I don't think is strictly true since I am using optical out via a Behringer interface box to the Behringer DAC.

But somehow sounds pretty good this morning, so when in doubt: reboot.

Still there are things that bug me. If I right click on the SPDIF Interface icon and choose properties, there is a "Levels" tab which seems to function as a volume control.

This is counterintuitive to me as I am trying to export bits, not levels.

I will post more as I learn if any other Windows 7 users might be interested.

Sounds like that "Levels" tab may be a digital volume control (always a big no no since they trade resolution when controlling the volume). Try setting it to maximum and see if it sounds better.

Make sure you are bypassing the internal windows mixer. SPDIF settings should not be coming into play when using USB output. In another current thread (near the end of it) here somebody posted a link to the dCS "cookbook" for setting up computers (MAC and windows) software to get "bit perfect" output. Reading a file, converting to PCM and sending the bit stream to USB port is a simple task that requires little resources. You just have to make sure that software stays out of the way as much as possible and not tamper with the bits.
since this is a laptop its likely that you are only willing to go so far, i.e. you have to strike a compromise between a dedicated server and a multitasking machine. The biggest degradation to audio transparency is (a) the audio hardware limitations (b) the jitter introduced by cycle stealing between computer processes... your audio card may have practically no jitter in a test lab situation but in a real life PC that doesn't happen without tweaking.

1) run your laptop off outlet power

2) setup a custom power configuration with all hibernate/sleep/idle options disabled... anytime the machine has to rouse hardware(video/CPU/HD/USB) from a power saving state it introduces audio degradation

3) if your BIOS has power saving options, note the defaults and disable (video/C1E) when playing music. Restore when on battery or your battery life will suffer

4) analog laptop sound card output is usually not great. Use ASIO if your only choice is analog out. Otherewise try to use digital to an external DAC. Kernel streaming is actually better than ASIO but can be more challenging to get working without stutters and dropouts

5) get DPC latency checker from Syscon. try to get your latency below 300 microseconds

6) once you have your latency cleaned up disable all audio buffering in your playback program or put to the minimums possible. I find that when I increase the buffers beyond the minimum for the output mode, the stereo image collapses.
CW, here's the link I was talking about:
Sorry, link was mangled. Try this:

Al and Davide really helped to solve the puzzle.

As mentioned above, I thought a simple reboot addressed much of the problem, but I finally had time this week to remember and take a closer look at the power and "sleep" settings.

Wow - that made a huge difference and really seems to have eliminated the problem.

Why computers would automatically do that with such bad side effects on performance without disclaiming them makes me crazy.

Why not set a machine for proper performance, and then be able to choose maximum battery life, while understanding that certain functions may suffer?

(But then again, I suppose most of the world thinks MP3 and iPod earbuds sound good.)

Later, I hope to spend more time with the geekier aspects of configuring PCs for audio as described in the DCS article.

IN the meantime, worrying about jitter, RFI and outlet power before changing the sleep settings, was a bit like wondering if I was using the right amount of spice when there was a dead rat in my soup.

Thank you all for expert advice as usual.
Cwlondon-I have had similar problems using M2Tech EVO
Converter with Windows 7 System. Installed M2Tech Driver,
with Converter. Couldn't get any Digital Signal to DAC via
USB to Converter. Went to Devices and Printers, could see
M2Tech EVO listed as attached Sound Device. Right click this, and ended up with about four different SPDIF Outputs.
What the Hell, set one of them as default, then finally
started recieving AES/EBU Digital Signal Output from EVO.
Can anyone explain to me what just happened? Aren't there
Instructions for something like this? Certainly not covered
in the M2Tech installation Manual! In fact, M2Tech
installation Windows 7 Software/Driver doesn't even match
step by step instructions in M2Tech Manual! PC Manufacturers have just got to do better than having
Customers flip coins for installation instructions. Is the Blind leading the Blind an acceptable Standard for PC Audio? Part of the confusion is that PC Manufacturers call
a PC Plastic Fiber Output as "Optical SPDIF". Audiophiles
for Decades have called it the dreaded "Toslink". A Rose by
any other Name......! Who are they kidding?

Well it seems I spoke too soon, my stuttering and popping in Windows 7 returned today.

So I opened this thread to review and went to Sound shortcut on the desktop.

Somehow trying to switch between audio devices, I may have deleted something.

Now, on both "Playback" and "Recording" tabs, it says: "No audio devices installed".

Thinking it can't be so easy to delete a critical device, I have rebooted, disabled and enabled anything I could see in Device Manager, but now, nothing - no sound at all.

A quick Google for "no audio devices installed" reveals I am not the first, but weird and wacky suggestions re the BIOS and/or reinstalling Windows and I am in no mood for that.

Can anyone please tell me how to restore the audio - or even better, install more of an audiophile set up as a default?

Thank you.
Can anyone please tell me how to restore the audio?
Try doing a Windows "System Restore," under Start/All Programs/Accessories/System Tools/System Restore (or else enter "System Restore" into the "Search Programs and Files" box under the Start button).

Choose the most recent restore date which is offered that is prior to when the "no audio devices installed" problem arose.

Doing that will not affect your music files, data files, emails, etc., but will undo any Windows updates, and possibly program updates or installations, that have been performed subsequent to the restore date. Those updates would therefore have to be repeated.

If the System Restore doesn't fix the problem it can be reversed to the present date, which would eliminate the need to repeat the Windows or program updates that may have occurred between the two dates.

Best regards,
-- Al


System restore worked - thank you.

Will continue to work towards a better understanding of audio in Windows 7 and a hopefully a leaner, meaner, audiophile configuration.
PC's come out of the box as a jack of all trades (or master of none). To get them to perform as a music server you basically are doing what any good stock car racer has to do... strip out the useless parts for a performance vehicle from the standard factory model and replace highway performance parts with speed oriented parts.
Needless to say most don't want "race car" compromises in a comfortable suburban ride.
Wow am I glad I found this thread. I have a old Dell laptop that runs like a snail in wet cement, but the sound is phenominal thru my Benchmark USB DAC. I was thinking of getting a new(er) version for the speed and screen but now I am haveing serious 2nd thoughts.

Re "comfortable suburban ride"

Comfort is the enemy of enthusiasm and the root of all mediocrity.

Long live enthusiasts and AUDIOgon,

Still hard to isolate this problem, but - whatever I do with the power settings - it seems like it is exacerbated when I am using more than one application.

Alternatively, if I close everything down and play just say, Foobar, for example I seem to get less skipping and sputtering.

Does this suggest a "kernel mixer" mixing problem?

I hope it is not too much to ask that I would like clean, clear, sputter free audio, whether I am listening to music or to Windows sounds.

Thanks for any updates.


You were right - but I made a mistake when I first tried to implement your fix.

I spent some time changing the power settings and choosing the preset menu for "maximum performance" and making sure that the sleep and hibernate features etc were all disabled.

As I mentiioned, things seemed better. But today was the worst sputtering and popping ever, despite "maximum performnance" power settings.

In the end - and you also mentioned this - the real culprit seems to be not the various sleep and hibernation options, but primarily the "throttling" of the CPU which is only found buried in the "advanced power settings."

So when the CPU options are expanded and set to minimum performance = 100 - that seemed to - at last - solve the problem, at least for now. It was otherwise unlistenable much of the time.

I will be curious to see if changing the CPU setting ONLY, while otherwise allowing the machine to sleep, hibernate etc might also work.

Thanks again and I hope this helps other Windows 7 64 bit users.
Great! Thanks for letting us know.

Best regards,
-- Al

Never thought we could improve upon the expertise of Al, but here is everything you need, in one clear and easy to understand document:

I am still testing but this has gotten me to the next level of clarity and quiet.

I may have mentioned that my latest notebook is a Lenovo X201 if anyone knows how to get to the BIOS.

The final step in the Sweetwater guide is double checking any CPU power management policies which may be disabled only in the BIOS.

Al thanks again and good luck to everyone who would like better sound from their PC.
Some computers work fine with Win7 and audio streaming (including HiFace) and others dont. May have something to do with AMD versus Intel etc. May be Microsofts fault, who knows. Even Microsofts driver for Gordons interface has caused some issues.

Just spend $500 and get a Mac Mini, or if you cant deal with Mac go back to XP or Vista. Solves all of this.

Steve N.
Empirical Audio
CW, thanks for the nice words, and for finding and providing the link.

According to this hardware maintenance manual, bios setup on the X201 is entered by pressing the F1 key when the ThinkPad logo appears following turn-on.

Many of the suggestions in the Sweetwater document look good, but I'm not so sure about some of them. Such as disabling ALL startup items and ALL non-Microsoft services in msconfig, and adjusting processor resource allocations for best performance of background processes instead of programs.

In any event, if you have problems as a result of any of these changes you should be able to get back to where you were via System Restore, which in the unlikely event that a change renders the computer unbootable can be run by booting into Safe Mode. Safe Mode is run by pressing F8 before the Windows logo appears at startup.

Best regards,
-- Al

Al and others,

I have not yet had the chance to delve into the BIOS, however, I have noticed another issue which I hope might help Windows 7 users.

My Lenovo X201 seems to revert to certain power saving settings every time it restarts.

By going to

> Control Panel
> Device Manager
> Universal Serial Bus controllers

I can then see a tree with "Generic USB Hub" at the top and at the bottom "USB Root Hub"

The challenge seems to be no matter how many times I adjust the power scheme settings, repeat the Sweetwater routine etc....

In the Power Management tab of every "USB Root Hub" item,

the box "Allow the computer to turn off this device to save power"

is checked. This may not be the only, final piece to the puzzle, however, it seems to make a significant difference when I go through that entire tree and uncheck those boxes.

I otherwise love this laptop and Windows 7 has generally been pretty stable for me.

In our increasingly multi media world, however, I find it pretty ridiculous that I have to manually uncheck several boxes every time I dont want popping, stuttering audio?!

Oh...and one last extra credit question for the experts, please:

In the midst of all of this, I have totally lost track of DVD playback.

I sometimes "rip" my own DVDs to the hard drive, which using XP were easy to playback using Windows Media Player Classic and all the same audio settings I used for music.

Since migrating to Windows 7, however, I can now see the movie, but the only audio is a screechy, staticky, digital which somehow hasn't been decoded sound.

Thanks for all ideas and help.
CW -- re the USB issue, try this.

Not sure what to suggest on the DVD issue.

Best regards,
-- Al

Regarding the DVD issue: download a copy of VLC media player from here. It seems to be one of the best at playing odd codecs.