MHT200 progressive scan video switching problem

I just hooked up the video components to my McIntosh MHT200. My Mcintosh MVP851 DVD player is set for progressive scanning and hooked into the component video 2 input. The HDTV box is hooked into the MHT via component video as well into the #1 component video input. When I'm switching from HDTV to DVD there's no issue with the picture but when I go back to HDTV from DVD the picture looks like it is still in progressive mode. I have to go to one of the AUX channels where there is no video signal programmed in order to "clear out" the progressive setting and then switch to HDTV.

When I turn off the progressive function on the DVD player, everything switches fine.

My questions are: is there a setting on the MHT200 to make it understand when to turn off and on the progressive scan?

or is there really that much difference between the non-progressive output?

Thank you for your help.
I'm just guessing here as I had a projector that had the same problem. The proj. was Sim2 300. When I made the change you refer to; I had the same result. I believe it to be the scanning frequency---Something to do with not recognizing the dif between film based 24 frames per sec. material/ and 30 frames-- material. I sold my projector. My now 1 year-old Mits CRT tv "blinks" a lot but has always made the change. You might look through the manual and see if there is some "auto-select" mode. Beyond that,call your MFG. I hope you get the problem addressed.