Hum from Plasma TV

My Plasma Tv is causing humi in my TT when its turned on. Sometimes I watch TV when listening to my TT . Other than keeping it off or moving everything can anyone suggest anything
to start with, some possibilities...

1. Is TV and hifi on the same AC line? If so, plug TV into a different AC outlet/breaker to prevent ground loop.
2. Is the speaker too close to the TT or does it not have enough isolation? Vibration from speaker can go thru the furniture, then cartridge and tonearm.
3. Are u using a grounding wire from the TT?
Try lifting the ground on 3 prong plugs by using a cheap 3-2 prong gray plug adapter from the hardware store. Try the TV first, then TT related equipment.
I did all the that stuff and more. What I'm thinking is the cables from the TT are picking up interference directly from the screen when the tv is on.
Maybe try some kind of shielded tone arm cable? I would move your TT as far away from the TV to see if anyhting happens. It's free and it might present a clue.
Is it a Panasonic? I had the same problem with mine while it was on warranty. Panasonic sent a tech to my house, he opened the back changed out most of the screws holding the PCBs to the housing. It mostly solved the problem, there is still some audible hum but it is really faint.

The issue was a loose transformer on one of the PCBs. They change all the screws just to be sure that it won't occur again on another board.

You can tell if this is your problem, if the hum becomes louder when the screen is white. My hum was coming from the top left corner.

Good luck, it is really frustrating!
I would have to rewire the whole arm to change the cables.

It is a Samsung tv. And it doesn't hum. The Ty is picking up hum when the tv is turned on.
Edit above

The TT is picking up the hum from the tv when the TV is on
Unplug the TV.

Keep it unplugged
Evank, sorry should have read the op more carefully.

Based on your system pics could it be caused by your centre sound bar speaker located below your TV?

Note that my TV is located as close if not closer to my tonearm than yours and I have no hum issues. Mind you my arm is shielded.

On the basis that the source may not be the TV, try running the TV without the cable or satellite decoder or any other device used in conjunction with the TV.

Hope this helps
How about wrapping the cable in tin foil and grounding one end? Probably look silly but should provide shilelding. Or braided shielding from a DIY shop.
Foil didn't help. Yes its when the power of the tv is on I get hum through the TT. It's not the soundbar. I would get the tone arm rewired but I hear it's a pain in the neck. Maybe I'll tackle that in the future.For now I'll just leave the tv off.
I have the same problem with a Samsung Plasma. It is definitely picking up interference through the tonearm wire. A huge amount of radiation come from the plasma screen, I was wondering if an LED TV would have similar problems? For half the price of a cable, could get an LED TV!! The other thought was to place a metal shield curving around the back of the TT earthed, to shield the tonearm?