Bah Hum Bug


I am having an issue with hum.Hum is only apparent in very quiet passages while listening to lps or when unit is in idle mode.Unit is Dead quiet..no hum in cd mode of operation.

I am running a Fosgate Signature Phono amp,Thorens Td124 with Ortofon Silver Meister Cart,Wright AU-1000 linestage, 2A3 SET power amp into Klipsch Heresy speakers.

When ground is is attached from TT to Phono amp the hum is intolerable so I run the TT with no ground to Phono amp.

I have tried cheater plugs and that has made no difference.

When volume is turned up say past 1 oclock in either the Wright or the power amp the hum is very noticable. Is this indicative of the high efficiency of the Heresys and 2A3 tubes? or is there some other thing going on here?

Please help.Thanks.
fromunda
Yes previous phono stage was Pro Ject Tube box MK11.
02-28-13: Fromunda
Yes previous phono stage was Pro Ject Tube box MK11

Well there, we seem to have narrowed down the problem area. Try a SS phono stage.
Yes but that phono stage did not have the hum-rush problem. Could it be my cart? the Ortofon SPU Silver Meister?
02-26-13: Fromunda
Fosgate sig was the last addition. But I believe the hum was there before as well.

02-28-13: Fromunda
Yes previous phono stage was Pro Ject Tube box MK11.

High efficiency system? Check. New tube phono stage hum? Check. Previous tube phono preamp hum? Believe so. Alright, what am I missing?

Sure, you can try another cartridge if that's what you want to do.
I had a similar hum problem. I had a separate ground from the turntable and one from the tonearm, both were grounded to the phono stage (no ground wire ran to the amp from the phono). Then I switched the ground from the TT to the amp and left the ground from the tonearm to the phono. The hum disappeared.