PS audio Directstream Junior locked


Hello,
I have been listening to Spotify Connect via ethernet into a PS Audio Directstream Junior with a PrimaLuna Prologue Premium Integrated without issue, but today I can no longer change the gain or navigate the menus. It boots up fine but appears to be frozen. I reinstalled Snowmass without resolution. I also removed the ethernet cable and rebooted, but it's still locked. Spotify will still stream through the bridge at a lower gain and USB no longer works.

Has anyone run into this issue or know how to resolve?

Thanks!
miguels
power off for a minute and retry.

If it uses an external power supply, check the voltage.
Miguels, a while back I had an issue with my DSJ though not to the extent you mention. In my instance I tried rebooting (turning off then on from the rear mounted switch) without success. I tried it again but before turning the unit back on I unplugged it from the outlet and left for 5 minutes or so before reconnecting and turning back on. In that instance it worked and I haven’t had a hiccup since. Not sure if that was the solution or not but worth a try.
I tried unplugging everything, rebooting, but still no luck.
PS Audio advised to hold the blue logo down and power on to reset. Didn't realize this was even a button, but it fixed the issue. Thanks everyone!
good deal and free to boot (pun intended)!!!
Good to hear miguels! I have been in contact with PS Audio service in the past and they have always be very responsive.