Hdtracks flacs at 96/24 but recognized as 44/16

I am streaming 96/24 flac files to a dac (w4s-dac1) from my MacBook pro using the toslink connection. The dac list the file sample rate to be 44/16.
The player I am using is VLC. What am I doing wrong

Did you set the Audio MIDI setup to 96/24? It is in the Utilities folder.
You might want to check the "midi settings". If the "midi settings" are set to "16/44" then the OS "down samples" the bit rate to match.
That was it, the settings in the midi section, never looked in there before. Thank you.
I hate to sound like an ignoramus, but I have been searching for the Utilities and Audio Midi settings on Windows XP to set for 96/24 or above, but I cannot find them. Am I looking in the wrong place? Are they in QucikTime. Help! I want to try running from my Samsung Netbook to W4S DAC2 Usb input and try out High Res tunes.

I found mine on the IMAC under applications-utilities - audio midi - and then under built in input - input - souce line in - let's me put 96 and 2ch 24 bit.

The other areas in that section will not let the 96 stand.

Is this the correct set up?
Windows settings are different than Mac settings.
There is no such setting in XP. Windows 7 has rewritten audio driver stack and it has a lot more control over the output. XP has rudimentary and archaic kmixer in the audio stack which does not allow the output bitrate. AFAIK kxmier will always resample the audio on the output, unless ASIO driver is used. For audio server it's highly recommended to use Windows 7. Also it's highly discouraged to use iTunes on Windows, as it'll add additional Quicktime layer to the audio stack and will make things more complicated. If you use Mac iTunes will work great. On Windows use j River MC.
Thx. I am trying to avoid complications, which is why I have eschewed computer audio so far.. Awaiting new Windows 7 laptop and will try it then. How do I set it in Windows 7?