Glitch with Wadia 861

I've got a minor glitch with a Wadia 861.

When I push the button to open the transport tray, (either on the unit or on the remote) the tray will open and as soon as it is completely open, it then immediately begins to close (and the display changes from "open" to "close"). In order to get it to stay open, I have to push open again while it is closing. The same thing happens when I finally get it to stay open, and push the button to close, it will close and then immediately start to open again.

Also, when this started happening, the tray seemed noisier when it was opening or closing. It was smooth and quiet when I first got the 861, and now it has a slight noise that sounds like a friction buzz when it opens/closes.

It doesn't affect sound quality at all, but it sure isn't functioning as it should. I did try unplugging the unit for over a minute, and then hooking it back up. That didn't help.

Has anyone ever run into this phenomenon before? I'm hoping it's something common with a quick and easy home fix. Any suggestions (short of packing it up and sending back to get it fixed)?

I had an 860x dealer loaner. Did the same thing and had the noise too.
My wadia 850 does this from time to time. Sometimes I have to hit the button more them once. it comes and goes?? it hasn't done it in a couple of months now. I do not get the sound you are talking about though??
I would also be interested to know why this happens?
I will email Steve at GNS and see what he has to say about this and let you know.
I have never asked him before as it always corrects itself
I've seen this sort of thing from time to time....both on my WT2000s and my current 270se. Usually if you reboot the machine it is fine. I agree with calling Steve Huntley at Great northern sound.

If you heard lots of noise from the 860x my guess is that it was a faulty unit...or the noise is elsewhere in your system. i've heard lots of 860's, 861's etc. Their great strength is the black background and dynamics.
Thanks for all your input. I also sent an email to Steve at GNSC just before I posted my original message here, so I expect to hear back from him early this week.

As far as the "slight noise", it is not very loud, and truthfully I just may not have noticed it until this little glitch started occurring. It could very well be the normal noise that the gears make when the tray is opening or closing.
This was an issue also with my GNS 861. The drawer began to unreliably open and close. Also, it would open and close at much slower speeds. Steve Huntley fixed it while he installed the statement mod. Apparently there was a motor that needed replacement.
I think I fixed the problem (at least for now).

I noticed when the drawer was closed, it was not completely flush with the face of the unit. The left side of the drawer was flush, but the right side slightly protruded, perhaps 1/16 of an inch beyond the face of the unit. So I GENTLY pushed the right side of the drawer in to try to square it up with the left side. Although it is still slightly askew (perhaps only 1/32 of an inch now), the drawer now opens and closes properly.

Go figure...but it works now!!
Sounds like the drive was slightly out of alignment with the front face plate....and you adjusted it. You may end up needing to open the unit or get it serviced.....but for now, I'm glad you got it working.