Looking for Primare PRE30 owners :


I have bought a second hand PRE30. It arrived only yesterday and I have noticed a glitch in its operation. Before I will send it back to service I was wondering if any other owner would be so kind and do this little test for me which will tell if the glitch is an design error or fault in my particular PRE30.

So what happens on mine is when use remote control to change volume and only after few full sweeps from zero to max and from max to zero. After about 3rd or 4th pairs (up and down) consecutive sweeps it will start randomly turn on "Tape Out" button on the PRE and switch the source to the one which is at that moment assigned to "Tape Out". I do the sweeps when music is not playing.

So I was hoping that other owner could try to replicated my glitch by doing this simple test of going for full volume by continuously holding volume up button and then to minimal volume by holding volume down button and repeat it 2 - 3 times. If tape out does not come in on yours in 3rd or 4th pairs of up and down runs then my unit is faulty otherwise it is a design flaw.

Thank you in advance.

Try a different remote. If you have a universal remote, that should be fine just to test to see if your old one is bad. Also, make sure you are not pushing the buttons on the remote too hard. Pushing too hard may actually pull down other buttons that are close to the one you are using.
Thanks for replay.

I have tried two remotes already. All the same. The pressure on the buttons is worth checking but I am not too hopeful.

Are you PRE30 owner by any chance?
"Are you PRE30 owner by any chance?"

No. If I did I would have already have tried to see if mine did the same thing. I've just seen a lot of remote issues. I know some of the other posters have experience with Primare. Hopefully, they'll see your post.
I have followed your idea and programmed my harmony one remote control to support PRE30 just to rule out possibility of proximity pressing on OE remotes as they seem to be a bit flacky.

It looked like it could it for a while but then then catastrophe had struck again and it was back to normal or rather not normal operation.

One user replied to me via PM on different forum that his is not having problems like mine does so looks like it is just faulty unit.

Anyway if anyone else want to chime in with either idea or test result please feel welcomed.