Sutherland PHD Question - Yellow LED blink right..

PHD owners......I am unable to find much with this issue, yellow LED starts blinking right after 2 minutes of play and it powers down. I have adjusted the sensitivity level to high and according to the manual, the yellow indicates handshake between turntable and phono preamp signal. When I move the ground cable, its back to normal and 2 minutes later...down again.

Could this be my SME interconnect cable or could it be the phono preamp. Dont have another table to test it at the moment. Will need to try another phono interconnect but would appreciate any suggestions. Thanks
Many years back had a similar problem except in my case the PhD refused to shut down. There is a thread on Agon about this. It's a handshake problem and try a different interconnect between the phono and the TT.
Thanks, I am in the midst of doing this, tried the cardas network box and not much luck still. I maximized the sensitivity level and its a little better, yellow light still shown up but much later.

Just curious what other owners are placing their sensitivity level at?
Does anyone know that if the battery is starting to get week, does this effect the features of the preamp (not the quality of the sound but just some of the other functional features, in this case the sensitivity control of the unit, does this weaken and needs to be readjusted accordingly) I think that is the issue, now I have increased the gain of the sensitivity level and the problem is not fully gone but better, intermediate occurance only now. My question is, could this be an indication that the battery power is getting lower and very soon, the red LED will be showing up during play?

Thanks - R
I believe I only have around 300hr of play and there should be still plenty of juice left.
Problem solved, needed a simple battery replacement (its been exactly 1 year) - Thanks Ron!