My PS Audio Power Plant died

I have all my home theater and stereo gear plugged into my Power Plant regenerator. It has worked great for 2 years. Yesterday the electric company turned the power off to our neighborhood for a few hours - a planned outage.

Tonight I went downstairs to watch a movie and everything was dead. There was a tiny blue light visible on the front of the PP, but it was not running. I pressed on the logo button which is supposed to turn it on, but no dice. There is some kind of little button on the back above the power cord but it didn't do anything. I looked at the manual but it was vague about what to do. It talked about a trigger and using a nine volt battery, but I don't understand it, it may relate to the remote control which I cannot find. I need help!
Call PS Audio, they are very helpfull.
I have had good results by contacting P.S Audio

It's probably not a lemon since it's been working fine for two years.

It was working before the power outage, but not after. Have you checked the fuse? Maybe there was a power surge when the power was turned back on.

I guess that an employee was working for 2 years (probably as stand-by), but failed to perform its duties when bad came to worse. That's why had been fired.
If you have not already done so, try unplugging it from the wall for a minute or two then reconnecting and restarting. If that fails, note what the display panel is showing and report the result to PS Audio. Mine worked well for three years before a similar problem as a result of an outage and had to be returned (at which point I was offered a great deal on a new P5 which I took, with happy results). Good luck and let us know the outcome.