Itunes keeps stopping

I am using Itunes to stream music to my system through a airport express. It works fine except recently Itunes keeps stopping. I have to go into Itunes and click on play again. It is starting to do this every song and a half. It is beyond being able to listen to. I tryed to restart the system that does not work. I removed Itunes from my computer and reloaded the program and that did not work. It is very frustrating. Any suggestions?
Maybe it's your Network.
Agreed, it's probably the network or interference from some other device (portable phone, remote printer, etc.). It could also be in some of the buffer settings within iTunes. I can't recall which are the usual suspects but you might do a search on optimizing iTunes/airport express streaming settings. Short of that an ethernet connection should solve it, but that defeats the advantages of wireless. If iTunes is not doing the same stalling while listening on your native host computer (not streaming) then you know it is not iTunes, but the network
I have same problem, started about 3 days go right after I did software update.
Just stops intermittently, sometimes for 5-10 seconds.
The iMAC and Airport are within 10 feet.
Never had this happen before, no solution so far.
I USED to have this exact issue, which is aggravating to say the least. (Not as much as world hunger, but you know what I mean.)

I have noticed that after I upgraded iTunes to 10.5.1 (currently the latest version), this hasn't happened. (Knock on head.)
Oh,the joys of computer audio !!!!!
My friend had these issues and I think he changed to a different "channel" for the wireless - something other than default. I don't remember all the things he tried. Although, if it just started happening, it may be something new.
From Airport Utility Help:

"Minimizing interference in an AirPort network"

"You may experience network performance problems if a microwave oven or other source of interference is used frequently near your base station or Time Capsule. To help minimize interference, turn on interference robustness."

Also, don't forget to update both OS & AE; my latest software update included AE which hadn't had an update for quite some time.
Both OS and AE are current. No microwave being used at that time. Latest version of iTunes installed when problems started.