HELP Frustrating DVD Player/Component Cable Prob

Here’s the deal.

I have an older 32” JVC regular-old-TV. (It’s the JVC-AV32D201 if anyone cares). For the last few years I’ve been using a JVC DVD player with this TV (DVD player is the JVC-XV540). Been running my three component cables out of the JVC DVD, into my Onkyo 502 receiver, and then from the Onkyo into my JVC TV. No big deal, I also run component cables from my Time Warner cable box into the Onkyo as well. This makes it nice and simple and I only need to run the one set of components into my TV and I can watch either cable or the DVD player.

The problem is that my old JVC DVD player broke. So I got a new one.

I got the new Sony 5-disc changer. The Sony DVP-NC875V. Nice unit, but when I hooked it up (via component cables) to my Onkyo the picture was only in black and white. So I hooked it directly into the TV’s component jacks – same thing. So I used S-Video – worked well (not as clear as component, but decent) but using the S-Video really screwed things up as than I could not keep my TV on the same input (the component input) and switch between DVD and Cable (I know this sounds petty, but I need cable and dvd on the same input so I can run my PS2 into the other additional input that allows either S-Video or composite, and I’m using the composite for the PS2…)

So since my old JVC DVD worked well, I figure that this new Sony DVD Changer isn’t able to output 480i from the component jacks. So I take the new Sony DVP-NC875V upstairs and I hook it up to my new Toshiba 14VL43 14in LCD flat-panel. I hook the Sony and the Toshiba up via the component jacks and nothing else. Works like a charm – crystal clear color and no B&W. Take the same box and cables downstairs and try them on the JVC TV and no dice – it’s a B&W pic. But if I switch the Onkyo input over to the Time Warner cable box, than it’s fine – full color on my TV (via the component jacks). So I know that the component jacks on my old TV work, I know the component cables work, and I know that the Sony DVD player works on my Toshiba but not on the JVC TV.

So I return the Sony DVD player and borrow my buddy’s Denon 1710 and hook it up. EXACT same response. Won’t work on the old JVC TV (via component jacks) but works like a charm on the new Toshiba 14” LCD flat screen.

Can anyone help me with this?

Why on earth do these DVD Players work PERFECTLY on my new LCD flat-screen (not a HD TV - just LCD) via the component jacks, but all of these newer DVD players only display a black and white image on my older JVC TV??? Again, my old JVC DVD player worked PERFECTLY with the A/V Receiver and TV via the component jacks….but none of the new DVD players I've tried work at all?

What’s up? I’m really frustrated by this one….


Long message and I may have missed something, but I think you need to try connecting the new DVD player directly to the TV using component cables and see if you still have the problem. If so, try a different cable. Also, be absolutely sure that you are connecting the cables correctly Red-Red, Blue-Blue, Green-Green.


Two possible problems come to mind.
1. Jack color coding is not alway standard. Check the labels on the jacks themselves.
2. As you said, "new Sony DVD Changer isn’t able to output 480i from the component jacks." The Toshiba LCD is able to accept a 480p signal, but the old JVC cannot. The Time Warner box has a component video out, but it is probably not 480p. Not all component video outs are prog scan.
Both players you tried, the Sony and the Denon, are set to progressive scan by default. Your JVC television does not support progressive scan. That's why you only got a black&white picture.

The reason your LCD display worked without a problem is because LCD is progressive scan by design - that's how an LCD panel works.

You must set the DVD player to interlaced to use it with your JVC.

The Sony changer you tried has a button on the front panel marked "Progressive." All you would have needed to do to fix your problem was press it to set the player to Interlaced.

When I connected a progressive (default setup) player to my old TV, I did not get B&W, I got total snow, bars, etc., no picture. Hopefully you are correct and the poster can just set the unit to interlaced and it will be fine, but I wouldn't count on it.


don't rule out loose coonect as componecy shows bw if loose.check on other tv.