Anyone heard the Krell Evo 402?

Was wondering how this latest model compares to past iterations from Krell?
Also if anyone has compared it to the FPB 400CX?
It is not even shipping until April. As a dealer for them, that will be the earliest it ships if history is any indication.

A few days ago, the shipping in Krell's Web was in March!

Thanks, Tomer
My dealer suggested they have lost any of their harsh edge (UK importer). This may be to no negative feedback. I have not heard them though.
The new Evos are a ripoff. I believe they cost far less to make than the venerable KSA-250 did 15 years ago. Now that was an amplifier. I don't see how an enclosed design such as that with internal heatsinks can dissipate heat effectively. The high end is killing itself. They might be happy selling a couple dozen to rich arabs but in the long run they have lost repeat customers such as myself.
I have one! Gave up the 350 MCX's for solid state I've heard so far. After 100 hours it is entering a very tube like phase...smooth, no glare, great tonal color. All vestiges of solid state edge is gone...completely! No more upper mid forwardness or brightness. An amazing advance on solid state design! Nightdoggy...good boy, rollover and go to sleep.
Update! I have the 402, 202 and 505. Cast sucks. Balanced is Transparent cabling and power cords are revelational!! I have the sense of being in the presence of live artifacts getting in the way..just music coming through!!
Dave_b - good to hear you've come across to the Transparent cable fold! I'm still having trouble getting the Reference power cable to give me the correct balance with the 505 - although the bass & mid is fantastic, the treble is just too hard. Well, it's either that or it's so ruthlessly revealing that I'm finding the treble a problem on some recordings. What power cables are you using now? Do you still believe the 505 has a problem with network cables, as I'm debating splashing out on Nordost power cables! Ouch!!!
I am running powerlink MM's on the 202 and the it turns out, the MIT Magnum AC 2 works great on the 505..go figure! FYI, the 505 took alot of run in until it settled many hours on yours? Remember, my first unit was defective..second one is flawless and works fine with the MIT, so why mess with success.
Hi Dave_b - Blimey MMs should be good! I've only got Transparent Ultras between CD/pre/power/speaker but Reference power cables (amazingly better than Ultras). The power cables are very full-frequency, and on the 505 it's probably pushing my poor old Sonus Faber Electra Amator IIs to their limits.

I've got Nordost Vishnu plugged in at the moment, and there seems to be less treble flying around, and the mid is sweeter, but the bass & general resolution and image is not as good. However, I think I'm still burning in the Nordost (5 days so far) so I'm witholding judgement.

I still wonder about your original comment of not using networked power cables with the 505, and I'm hoping someone from Absolute Sounds (Krell importer in UK) will give some guideance. I believe your MITs are networked and they're obviously working fine.

I am beginning to think the issue lies with my poor old speakers, but I can't afford that upgrade at the moment! (Amati's are tempting)