Need some help-eliminating hum

I am not sure if this is best place to post the issue, but here is my issue and troubleshooting to date. First, i am considering a set of cables from Bob's Devices to solve the hum but wanted to see if I am heading down right path. I recently added a pass labs xp10 and xa30.8 as my first foray into separates. I have a marantz sacd as my digital player and a maplenoll Apollo w zyx UNIverse ii and the zyx artisan phono preamp.

Since the cartridge requires more boost, I have increased my preamp volume up and started noticing a hum. My digital is sto e silent as expected at same volume setting so I know my preamp/amp is solid. I have a set of MIT cables (entry level) and audio research cables around my zyx artisan.

My turntable arm is carbon fiber and does not have a true ground. I know that could be an issue but my troubleshooting indicates a shielding issue i think. The unit hums when turntable is off and hums when it's unplugged. I disconnected the cable from the table and it still hums. I disconnect the input cables from the artisan and hum stops. I swapped the position of the MIT and ar cables and the MIT hums less. I can move the cables around and this varies the intensity of the hum. I have repositioned the preamp and artisan to get min hum? I have grounded all components and this does not change hum. I know these two cables aren't the greatest when it comes to shielding hence my thoughts of Bobs cable. He will accept return if that does not solve issue

Are there other things I should do before pulling trigger on the set of better shielded cables
I concur that your cables are exhibiting causal evidence. I don't think it's too strong a statement to say that phono cables need to be shielded. Since they are picking up hum from some nearby power supply/transformer, most likely from a power amp, try to move that away from the scene. Any mainstream-brand shielded cable should be sufficient to prove/disprove without having to spend $$$.
I'm not familiar with either of the cables you are using so the question is, are either of them shielded? If so, what type of shielding is used? Also, what length are the cables?

I ask as I have some shielded cables which perform well as far as noise rejection. If they could help your situation, your welcome to them.

Chasing hum problems can be a nightmare.
I have the MIT EXP-3 running from the table to the preamp. this is an entry product by MIT and is about 7 years old or there abouts. It is a balance set and is shielded. It performs better than the "cheap" pair of AR interconnects that i have been using from the phono to the preamp. NOt much at all on shielding there. THe length is .7 meters

I will send message with contact info thanks