Will a Sonos Connect Zone Player 90 recognize 5G

My Squeezbox Duet does not recognize my new 5G network and is plagued by frequent dropouts on my 2.4G network. Looking at the Sonos Connect ZP90 but I cannot find out anywhere if it will recognize and work on a 5G wireless newtowk, does anyone here know the answer?
I do not believe that the Squeezebox, or any other streaming music player I am aware of, supports 5G WIFI (but I could be wrong). It's too new. It should work just fine on your 2.4Ghz network.

There could be many reasons for dropouts including weak WIFI service (too far from your WIFI access point), overcrowding on your network, too many 2.4 GHz networks competing for service (do you live in an apt.?) or maybe you just don't have your router/access point configured correctly.
I do live in an apartment and pretty sure everything is configured right. I have noticed when I turn the squeezebox completely off then back on the dropouts seem to stop. Go figure.
One thing that you could try is going into the admin screens for your wireless router and changing the channel that it is operating on. Most of them come configured for channel 11 and hardly anybody ever changes it. It's not too hard to imagine a lot of wireless routers in an apartment complex confusing each other. I run mine on channel 3.
Djohnson thanks for the info but I am a computer moron, I have no idea how to change a channel or even that there are channels. I will check into it and report back thanks.
Wireless routers come with a default IP address set for them. This is usually but depends on the brand and can be changed. If you can find that address, use that as the location in your browser. You should be presented with a login screen for the configuration screens of the router. Hopefully your router has an admin password and it is written down somewhere (username is probably admin). If it doesn't have a password, you need to set one to prevent easy hacking. Once in the configuration you should be able to find the setting for changing the channel (check the manual).
Djohnson thanks for the advice that did it! Changed it from auto to channel 1 and for two solid days now no dropouts! Thanks again!
Terrific. Glad that was it. I think a lot of the issues that people have with dropouts and wireless routers are related to the channel. It's pretty silly that they all ship with the same setting.