Why does my Benchmark DAC-1 keep blowing fuses?

I have a Benchmark DAC-1 (original version). It's a stock unit except for a Cardas Golden Reference Power Cord I have been using on the unit for 2 years without problems. The PC is running into a Panamax Max 1000 Power Filter AC filter, which is running into a PS Audio Power Port (original version).

I recently had a power surge in my home. All of my equipment survived without even any other blown fuses, except for the Benchmark. After the surge I noticed that the Benchmark does not have power. I tried plugging it in to anothe outlet but nothing. I pulled out the fuse tray and saw that the fuse was blown. The unit takes .5 amp 250 volt slow-blow fuses. I bought equivalents at Radio shack and powered up the unit. The replacement fuses immediately blew.

Is there another fuse I should try or should I assume the unit needs custom repair work?
First I would contact Benchmark and make real sure that the fuse is the correct value. If it is DO NOT put in a larger one (otherwise you WILL cause more damage). You will need to have the DAC serviced.
On the other hand check with panamax and ps audio to ask if they warranty devices hooked to their equipt that has problems due to surges etc.
Fuses do not always protect components from damage. Sometimes they do not open quickly enough to protect power supply components from damage. Return the unit to Benchmark and let them troubleshoot the problem and repair your unit.
Benchmark does have a 5 year warranty, If I remember correctly.
Thanks folks. I will contact Benchmark. What is strange is that no other components in the system were affected, and for that matter no other electronics in my house were damaged. It may not even have been a surge. Just a momentary power outage. The fact that replacement fuses are still blowing means that something else is awry (resistors?).