Wadia Dock failed after iPod touch to V4.1

I have a 64G iPod touch that was working perfectly until I updated to V4.1. After the update the music would skip, all file types, it sounded like a skipping disk. I worked with Apple extensively with Apple and ended up receiving an exchange iPod touch. The new unit worked great and was loaded with V3.1.1. After about a week iTunes presented the update to version 4.1, so thinking my last iPod had a failure I went ahead and updated and ended up with the same problem. Has anyone have/has this problem and have or know of a fix? The Wadia is fine as other iPod touches work properly. Do not upgrade to V4.1!!!
There are threads about it on Apple's forum. A gentleman here has the same problem when using his iPhone with an iDecco. A lot of car docks have the problem too. Appearently Peachtree and others have been told that Apple is working on a new update to fix the issue.

I had problems with my iPhone working in my car the first time I tried it after the update. No problems since though.

Hopefully they'll fix it soon. A lot of people aren't too happy right now. It's not the iPhone itself or the docks, it's the iOS 4.1.
My iPhone 3G was perfect until I updated it to 4.x. Pandora and LastFM both crash all the time and I just hate the fact that once updated there is no reverting back to a lower OS!The phone itself also seems sluggish after the update, whereas before all transitions between apps was smooth and Mac like...

Best rule of thumb in the digital age: don't fix it if it ain't broke!
My solution to this was the Apple Store. I explained what happened, even though they had no clue what a Wadia dock was without explanation.

At any rate, they exchanged my iPod with one that had V3.1.3, now it works perfectly. Mind you, my iPod was still under warranty and from here forward I'll approach updates with utmost caution.