VPI SDS 45 RPM malfunction

I have a brand new SDS unit that I've used for about a month now and it's been working fine at 33 rpm, but last weekend I tried to put on a 45 rpm record and the unit malfunctioned. I was able to adjust the frequency up to 80.80 Hz, which the strobe indicated resulted in correct speed, but the voltage would flicker between 72 and 115 V for several seconds and settle at 72. It seemed the turntable was holding speed at 72, but when I put the record on and the periphery ring, the SDS kept going back and forth in frequency between 33 and 45 (up and down between approx. 60 to 80 Hz and the motor would audibly "slip" when the SDS got to 80.80 Hz and then started going back down).

Is this a matter of adjusting the unit or is the unit broken? I sent an email to VPI, but I know they are very busy so I thought in the meantime I'd ask here. Any ideas or suggestions?
I just wanted to add that the belt does not slip at 33 RPM at all, and the platter holds the speed fine.
I bet you have the 300rpm motor. It sounds like you will need to change the capacitor value within the motor assembly. VPI can recommend an alternate cap value that will prevent your motor from hunting for power when running at 45rpm speed.
Thanks Brf. What's strange is that I had an SDS unit before, and it worked fine with that same turntable at both speeds. Never had a problem or had to adjust settings.
Try stepping up the SDS run voltage from 72v to something higher. I would start at 75v and increase the voltage until the voltage stops varying between the run and startup voltage.
If I remember correctly, the run voltage was higher for 45 RPM, but it would adjust itself automatically once you switch from 33 to 45. Also, I'm not quite sure how to adjust voltage since it comes pre-calibrated from the factory.
definitely sounds like a malfunction of the SDS. I don't currently own one, but did for several years and it shouldn't be acting like this. Your voltage should set automatically based on the speed / Hz yoy dial in. For it to fluctuate means an internal problem only VPI is likely to fix.
Go to VPI's website and download the SDS calibration manual. In the manual are detailed instruction on how to adjust the SDS "steady state" voltage (run mode). For 45rpm, the factory default should be either 90 or 102 depending on the software version. If your SDS is dropping from 115v to 72 v after startup when in the 45rpm setting, it needs to be adjusted higher. You cannot hurt your table by trying a higher steady state voltage. I hope this corrects your problem
Brf is right - definitely worth a try.
It is easy to set the voltage drop. Just read the manual, 72 volts is too low to reliably run 45 RPM on my SDS as well. Try a higher setting , it worked well for me.
You said it is a new unit?? Send it back to VPI for proper performance.
A month old ,...SEND it BACK,...geeze
If I can re-set it myself, why would I send it back to VPI and wait for who knows how long to get it back, new unit or not? Btw, the calibration manual may as well have been written in Chinese. I can't possibly follow it, but at the same time it cannot be that complicated since adjusting voltage only involves user accessible front panel buttons, as far as I understand. Anyone here can provide a quick tutorial? It'd be greatly appreciated.
Go here: (http://vpiindustries.com/manuals/CALIBRATION_MODE_FOR%20_SDS.pdf)
Turn off the unit and disconnect it from the turntable.
your fingers on both arrow buttons, turn the unit on.
your fingers from the arrows within two seconds of turning
on and seeing, "CAL" displayed on the left. Press
the RPM selector button repeatedly, until, "C5" is
displayed on the left and the run voltage on the right. Use
the UP/DOWN arrows to select the voltage you desire(I'm
using 102V). Press the RPM button again, to return to,"CAL"
in the left display, and press an arrow button to exit the
CAL mode.
If your unit doesn't allow you to set your desired
voltage(probably higher than mine), send it
back to VPI.
Thank you. Is this calibration for 45 RPM only? 33 works fine at 72V and I'd like to keep it that way.
The unit appears to be broken, strangely for the 45 RPM function only. I tried to recalibrate it, and it was factory-set to 102V for 45, which should work fine. I increased the voltage to 115V to see if that would do the trick, and the result was the same. Thanks all for your feedback and suggestions.
For future reference; C4 is the function, for setting 33.3 RPM run voltage. Too bad setting voltage wasn't the issue. Hopefully, VPI's Repair Dept will be on the ball, and get you back into operation quickly!
Contact your dealer in which you purchased he SDS, perhaps they can simply exchange the unit or loan you a SDS while yours is getting repaired. Your Dealer should make the situation rate.
Post removed 
Probably the belt. Best of Luck