VPI Scout damping fluid

I have had a Scout for about 2 Yrs. now with no issues until now. The arm used to drop slowly and now it drops fast. Does this mean I need to add fluid somewhere? I bought it from a dealer already assembled. Am I better off without fluid? Does this happen to everyone or do I have a leak? I don't see any fluid on me cabinet top.
I had the same problem and was told by VPI to try to tighten the allen screw first. That didn't work so I sent it in and they replaced it. Great service, by the way. There's no fluid in there.
It happens to everyone.

I haven't bothered getting mine fixed.

Contact VPI tech support.
Thanks guys, I will call VPI tomorrow.
Can anyone tell me the specifics of the problem being described here?

The fluid leaks out. Normally, one would lower the lever and the tonearm would slowly lower into position. Once the fluid leakes out, the tonearm lowers directly with the lowering of the lever.

I don't think anyone has come up with a DIY fix yet.
I had the same problem when I had my Scout. For a quick fix I lightly pulled up on the arm rest and it seemed to fix the problem (at VPI suggestion). I would also loosen and tighten the allen screw which I also did at VPI's suggestion. There is no fluid.
I got in touch with VPI today and when they receive their next batch, of the lever assembly in, they will send one to me. Very nice to deal with.
Thanks for your help
Hey - they didn't offer me a new one!

Dirty rats:)
Does anyone know what fluid is used in this device? I want to try a DIY before I fork over the $40 that VPI quoted me to replace the lifter (plus I have to ship this one back!!!!)

Thanks and sorry for the new thread requesting same information. This shouldn't be rocket science.