voltage/polarity issues with isoclean transformer

I need a bit a help here. I have had 2 PT-3030G II Isoclean isolation transformers for some time. I am in the process of re-wiring my ac distribution. Since I am building some new power cords to and from the Isoclean transformers, I pulled out a voltage tester to confirm polarity and voltage. (I never did this before on the Isocleans). I am getting reversed polarity and "off" voltage readings from the entering side of the transformers to the exit side. Neutral and line voltage are reversed and the exit voltages are not where they should be in many cases. Has anyone tested their isolaton transformers voltage and polarity? Do isolation transformers reverse polarity? Of posible further interest, I found some interesting readings coming out of the Isoclean 80A and 50A distribution boxes as well. I have not contacted Isoclean but will. Any thoughts? Thanks
I have not tested the transformers in my system but I would be very interested in the result of your inquiry. Please keep us posted.
That is normal for any a/c transformer (isolated or balanced).

Update. I am in conversation with Isoclean, They responded quickly and i am sending them detaild readings. Nice.
GMC, I wonder what "interesting" readings means. I have checked the voltage which has been stable and constant across the outlets on my 80 box. Remember that it does have filters,
Tbg, if i can recall, I was getting almost equal voltage readings between the ground and hot and between the ground and neutral. A simple test with a polarity tester showed open grounds on the outlets. These readings, while interesting, seemed plausible, considering the filtering.
Gmc, equal voltages between ground and neutral and hot? Are you certain that the IsoClean is wired correctly. Would this not cause the circuit breaker to trip? Oh, I keep forgeting that you are talking about the filter box. I no longer have the IsoClean filter box, but on another filter box I get only 2.9 volts from hot to ground and 0 from neutral to ground.

Please post when you hear back from IsoClean.
My PT-3030G II reads 61.2v (ground to 0 output) 62.2v (ground to 117 output) for "balanced operation". One of those readings should be negative, but my testmeter did not show it.
Tweakmenow, I think Gmc is talking about on the outlets of the filter box. Your reading do show balanced operation. Is that a choice of hooking them up?
Tbg, I have attached the wiring in the only manner possible for 120v operation.
Tweakmenow, so they are balanced power transformers. I have never heard that before.
helow ! the isoclean transformer is balanced ?
Igallasri, try checking the voltage to ground of both the hot and neutral. Yes, they are balanced.
yes is Balanced transformer.....