Vandersteen 2WQ Subs and ARC Power amp


Just purchased a pair of 2WQ subs in very good condition.  However, the variable crossovers that came with them were single ended, so elsewhere I purchased the fixed balanced versions, marked with "150K".  The seller assured me that was the proper value for my ARC REF 150, which has an input impedance of 300K.

I have very little, if any, output from the subs when I use these crossovers.  Do I have the wrong values for this amp?
Ag insider logo xs@2xscottwsmith
The bass from the 2Wq's should really be loud, boomy and obvious without the crossovers. In fact be very careful doing that because you can damage the subs internal amps if you turn up the volume too loud. I had bought a 2Wq new, and it works very well. I bought another 2Wq used, that looks almost like new, but when I powered it up in combination with the other new sub, it doesn't sound very good at all. I am going to send the amp in (taken out of the sub) to Vandersteen to be rebuilt. I also think the two adjustable pots on the back of the sub might also be damaged due to age.

First and formost,, make sure you get the right crossover values for the input impedance of your amp. Contact Richard Vandersteen for all your concerns. Cost for repair of plate amp starts at $225 plus shipping. Good luck.
You probably do have the wrong values...also, when were the batteries changed?
@stringreen 
Excellent point.

@mr_m ,
My subs have never been loud or boomy, in fact very subtle. I can only 'hear' them if I disconnect the speakers and play the subs separately.

@scottwsmith ,
Though mr_m gave you a caution, I would be hesitant with hooking up the Subs without the crossover.
Like I said, PM audioconnection, or leave a message with Mr. Vandersteen.
Bob
The crossovers are X-2B, fixed values no batteries.

Scott...don't you have batteries in the silver box where you change the input values?