Turntable sounds fast/high-pitched AGAIN

I posted here a couple months back about my turntable sounding slightly fast/high pitched. Well, back them, the problem was a very stretched belt. So, I replaced the belt, and it sounded normal again. After replacing the belt, a few weeks later, it started to sound slightly fast/high pitched again so in frustration, and it's only gotten worse with time. I'm positive my turntable is running a bit fast, but don't have a strobe to check it. If it is running fast, and the belt isn't a problem (since I upgraded it a couple months ago), what should I do to get the speed back to normal?

I have a Denon DP-300F automatic turntable that I bought secondhand. It's got a built in pre amp My cartridge is a Shure M97XE.

If you're at all technically minded, you may be able to locate a service manual at VinylEngine.com . Or look up that turntable on AudioKarma- lots of knowledgeable folks there. It's possible that there is a calibration pot that can get you back to the right speed, or the turntable needs to have new electrolytic caps installed. You can probably find a strobe disc that you can print out online.
Go to Vinyl Engine website and look in the printable protractor area as there are some printable strobe discs. These can actually work off the flicker of a regular incandescent light bulb (if no other light sources are present). Will give you an idea if it is the speed at no cost except a sheet of paper and printer ink. Make sure to follow the printing instructions to ensure the size is correct. You may have to join Vinyl Engine, but it is no cost.