Trouble with my Rel Storm III

My newly acquired Storm III stopped working yesterday (2 weeks after buying it here on audiogon)When I turn the power switch from the off position to the on position, I get a gong sound...then nothing. I have tried it in all the other high level it is probably not a switch. I am trying to figure out if it is the amp, crossover or driver. Anyone have a similar experiance?
Just for fun - try the fuse first.
It does get power...the fuse is good. I wish it was that simple!
Check all the connection from the amp if you have hooked up +/- to left speaker output and + to right speaker output.
My Strata III on/off switch is giving me problem after 3 yrs of use, I have to wiggle the switch few times to get it going.
I had one of these and mine did the same thing... it was the driver in my case and had to be replaced. Try moving it around if possible while it is powered on to see if you get that gong sound. Mine did that as well so I had it repaired then sold it.
I've never had a problem with my Storm III. From what you wrote, I assume it was working fine before it failed. It may help folks help you if you describe how do you have it connected and the other associated gear you're using it with. Have you tried it with other gear? Same result? How about a different connection (eg low level vs high?). How about the cable? Have you checked it for continuity?
I thought my Storm III amplifier was going bad and talked to Immedia, the REL importer, who were going to send a box and instructions for returning the amplifier. It turned out to be something else, but I would recommend talking to Immedia and see what they say. Bummer that it seems to be going out. I hate nothing more than to go out to listen to music and having to spend time trying to find out why something isn't working.
Thanks you all for your help. I tried everything suggested and more. I called Sumiko in Berkely, Ca.( is Immedia and Sumiko the same Co.?) and they said they would repair it....but made sure I knew they were doing me a big favor. After all I was not the original owner and did not have proof of purchase from an authorized Rel Dealer!... So I took it to Magnolia Hifi, I would rather give my money to a company that gives good service with a smile!