Tidal/OPPO streaming issue

I have been streaming Tidal through my oppo 105 for about five years at this point. Last night when I went down stairs to listen to music I got a window pop up on my Ipad screen that said invalid login token. I have never seen this before and could not get logged in no matter what I tried. I have a pair of Bose powered speakers upstairs hook to my computer
 just for non critical audio and could log in and browse/listen no problem. So I know my account is active and paid. Anyone else experience this and if so what was the fix? This is how I listen 90% of the time and almost every night for at least an hour or two. My only hobby/relaxation really. Very frustrating!
Working again.  I think I may have found the issue.  I have a Teac NT-505 that is my primary streamer in my main system.  The Oppo is in the basement system.  I had the Teac up and running.  It was connected, but not playing Tidal.  I decided to check on my Oppo and it would not play.  The app recognized the Oppo, and Tidal loaded, but it just would not play.  Today, before I turned on my Teac I decided to try the Oppo.  It worked flawlessly.  Wondering if something disrupts things when both streamers are connected to Tidal.  Anyway, I’ve tried it 2 more times and it works great.  I just make sure my Teac is turned off.
Ok, the Lumin T2 came in yesterday about noon. I have spent some time with it and it does sound very good. I am unimpressed with the playback app. I think I must be missing something as I can only play one selection at a time unless I click on each song on an album to put it in the que. I surly must be overlooking something as this most incontinent. I can't believe this is the way it's intended to work. Does anyone have any first hand knowledge of playback through streaming services? Thanks.
The Lumin app kind of sucks.  If you want to play an album, long press on the title, than a sub menu will pop up giving you the option to play all (an arrow with lines below it).

I've been using BubbleUpNP.  I think it's about 5 bucks for the version without ads.  There's a free version you can try to see if you like it.
@trinhsman I do think there are issues with the network state that cause Tidal to not function. I am running Audirvana-Tidal. I had aabout 2 weeks of issues. I posted on the Audirvana forum and one of the code monkeys told me to change my browser DNS setting to Google's - I did that and the issues were better until yesterday... when I had a heck of a time connecting to Tidal resources again
The Lumin app really takes some getting used to.  Kind of like an IPhone.  Just figure it out.  Anyway, to play a full album, when you find the album, click on the album picture and hold it.  Some icons will appear.  Select the one that has an arrow under the horizontal lines.  That should make the whole album play.  I also select favorites as soon as I can, so I have a long list of favorites.  Then I can go to the favorites and select the tracks icon, and then have music for hours.  
The only thing I can’t get this to do is make a radio station like Pandora or Spotify.  
Best of luck!