Sudden problem with turntable


I have a rega p5 with a ortofon black. it used to sound great. yesterday i put on a record and it sounded terrible, really muddy. My knowledge of turntables is very limited. Is it possible that i damaged the stylus? Any suggestions as to how i would determine what happened?
929a6b3d 01cd 4a84 8af7 65402ece9921jkontuly
Do you regularly clean the stylus on your cartridge?

Have you looked under magnification to see if it is clean or dirty?
Buy a box of Mr. Muscle Magic Eraser. (seriously). Lower the stylus onto the block. Raise it. Lower it, raise it. All set.
Do not drag it over stylus. Ever.
Mr Clean Magic Eraser. Search threads here and you will find one on how to use it.
What phono stage is it running through?
I had a guy in college call me with this exact same problem. Can you help me? Yeah sure I'll come over but it'll cost you a beer. No problem man, please help me!

So I walk over to the turntable, flick this big wad of lint off the stylus. Man you're a genius! Sounds great!

This was 1977. Back when everyone played records. Yet even then hardly anyone had any real idea what was going on. Today, all these people coming back to the audiophile niche that started it all, kind of surprised there aren't more questions like this.
Thanks everyone who has replied. I was having some difficulty logging back into this account. I did use the brush to clean off the stylus but am going to try the magic eraser tomorrow. I have high hopes for this. Regarding the photo stage it is a black cube. 
You might also consider cleaning your records with a SpinClean -$60 on Amazon. Pick up a gallon of distilled water. It is an excellent product and simple to use. 
If the problem was really a stylus booger you should hear immediate improvement after a soft brushing.  Let us know if it removed the muddy sound.  I also use the magic eraser and SpinClean.
+2 Magic Eraser. +1 just wasn't enough. Cheers,
Spencer
Before trying anything that will cost money... Did you try putting the same lp on that you listened to last? If so, it could be you're now listening to an inferior pressing?
Could you or someone bumped your counter weight and added tracking force, your head shell screws were loose and cartridge moved, to troubleshoot you could back off on tracking force or adjust vta. Did you check the suspension of cartridge was riding low close to album? I use magic eraser, I have a vpi machine but get best results cleaning albums with a hand held steamer with cleaning solution and rinse with lab water or distilled . Hope you find problem it can be aggravating, been there.

I tried the magic eraser and that wasn’t it. I think I will need to check everything from scratch, including cartridge setup, platter level, ball bearing lubricant....Never done that before so it should be a good learning experience. The odd thing is it seemed to happen quickly went from sounding good to slightly slow or hollow. Just missing something and I can’t put my finger on it. Very annoying. 
Go to Vinyl Asylum and download the best protractor for your arm, put it on your table and follow the lines it's easy. If you think it's low on oil maybe from shipping don't use it till you top it off, look in there with a flashlight. First thing I would do find recommend tracking force for your cartridge and see what your tracking force is set at, to much force will dull sound. If you don't have a tracking force gauge make the arm float with the counter weight,set dial to zero without moving counterweight, then turn counterweight to cartridge recommended tracking force. Just be careful of not damaging needle while making it float. 

I'd vote against that last suggestion. You can get a surprisingly good digital stylus force gauge in 2 days or less on amazon for about $11. Cheers,
Spencer
Sorry, meant Vinyl Engine for protector

Could it be that the suspension on your cartridge has given up the ghost and collapsed, and (at the worst) you're just dragging along on the cartridge body?  
Bpoletti I can take a look. I know the cartridge isn’t dragging but how would I tell if the suspension is sagging. I am ordering a digital stylus and jewelers loupe and have also downloaded a protractor   
Check the VTA - vertical tracking angle. I had a very similar, very frustrating experience recently, and taught myself to adjust the height of the base of the tonearm. I raised it up and then slowly lowered it down in increments until it hit the spot where the sound was clear and beautiful again.
No love for my suggestion that would have cost you nothing. Too late for it now. Good Luck!
It’s the same physical album I have listen to many times so unfortunately not the pressing. 
Do you have HiFi News test lp? That might offer some clues...cheers,
Spencer
Take the cartridge out and send it to Soundsmith....you'll get back smiles again.  Don't bother with anything else since this happened suddenly....not a setup or cleaning suggestion.
Do you have other sources? Sound okay? If not, could there be blown tweeters?
Yup, input for DAC sounds fine. 
+1 @stringreen but since the OP is using the Ortofon 2M Black (as opposed to any MC) he can change the stylus at a lower cost. This is assuming that it is stylus damage, and suspension is still good. As the OP has described this change as being sudden, and dramatic, my suspicion would definitely be on the stylus
Just re-read the post again. My bad. I thought he said the 2M. If it is the Cadenza, Soundsmith would be an option, but be prepared to wait for it to come back. My last cartridge was there for 2-3 months
might be a dirty stylus
@jkontuly Any updates? I hate unsolved mysteries!
unfortunately no. I have been swamped at work. Hoping to try over break to fix myself, re-oil bearing, set-up cartridge etc...if that doesn't work I will take it to audio element in pasadena and see what they have to say. I think it would be a good learning experience to at least try...or dangerous..

So I thought I would update this thread. As it turns out the magic eraser did help solve the issue. I didn't think it did at first but when i got the jewelers loupe and looked closely it turns out that I didn't get all of the eraser off the stylus. Once I did that it was all good. Thanks everyone.

So I thought I would update this thread. As it turns out the magic eraser did help solve the issue. I didn't think it did at first but when i got the jewelers loupe and looked closely it turns out that I didn't get all of the eraser off the stylus. Once I did that it was all good. Thanks everyone.
Sweet!  Glad you solved the problem and it was a cheap and easy fix.
Post removed