Spotify premium doesn't see node 2i as avail. device


I have spotify premium and everything works except for Spotify recognizing my node 2I as an available device. The node works with my added usb, my internet radio stations, by both wifi and ethernet. Bluetooth works as well from my phone to node, but spotify, which once worked with a different router, no longer does now. It’s crazy because the wifi company can see my node on the ethernet and sees it as a wifi device as well. My phone sees the node for Bluetooth device. All items have been repeatedly unplugged, rebooted, uninstalled, reinstalled, etc. I am absolutely loosing my mind with blusound saying it’s spotify and spotify saying its a blusound node issue. GRRRR!
Real ideas please! Also, at this point, I’m not opposed to selling the node and finding the next higher level of streamer  that will do what I want well. So, any ideas on what that may be? Again, and I can’t reinforce this enough, ... GRRRRR!
4342b7d3 d980 4bec aac0 282f8da1ee60labguy
Sorry about your conundrum—I feel your pain.  Why not upgrade your music source instead of the streamer and try Qobuz.  Sounds better than Spotify and it’s free to try.  Sorry I can’t be of more help, but best of luck in finding a solution.  
I tried both Qobuz & Tidal. I wasn't crazy about their format.  I already have a fair amount of music saved in stored with playlist on spotify which is convenient.
You have offered developed solution that is probably the lesser of all other evils & I appreciate that.  It's just frustrating when something is advertised to integrate and then I'm unable to utilise features that have been sold
Update your Spotify account, then go into the Node and reselect Spotify as a source. This will, in a sense, reset Spotify to show the Node. It won’t show until you tap “airplay or Bluetooth” through the Spotify app itself. Then it should come up.
Spotify on my iPad and iMac see my Node 2i and connect through wifi without any issue. 
You on the same network?
Spotify Connect should work like Tidal Connect does.
BTW both Qobuz and Tidal have pain free playlist migration.
Try deleting data on thee BluOS app. That usually does the trick with a reboot.