Sony Blue Ray: S5000es vs S2000es

I have the 2000es which is driving me crazy with extremely slow load times and inconsistent performance. The picture and sound are great, when they work. Player seems almost too sensitive to a less than perfect disc.

I'm wondering if these problems were fixed with the next-generation 5000es or whether there is better performance to be found with another brand/player. The PS3 is not a consideration.

Thanks for your assistance.
I just received my new Sony S350 and LOVE it! I can't believe that there could be much of an improvement over this unit. Pretty fast load and response time, (as compared to my Toshiba HD-A2, which was MEGA SLOW) and so far it has played flawlessly every disc that I have tried.
I have the S5000es; and I find it to work very well; I am using 5.1 analog out; and having the BD process the new codecs; running it into analog input card on Meridian 861. I have played both standard dvd and blue ray; it's load and start times are very good; and I've had no problems with difficult to play...
Unfortunately; most of the bd discs I've used are only 5.1 dolby digital; few have new codes on them; not sure I've heard big benefit of improved sound; but picture is exquisite. Lot's of options in this price point; the sony is a bit steaply priced.
Thanks for the responses so far. Just talked to Sony and they are sending me a firmware update disc to take the player from Version 3.0 to the current 4.3. Hopefully this will fix my frustrations.

Mribob- Do you have a feel for what your load and start times are for Blue-ray discs with your 5000?

Does the update disc fix the 2000 so it will play dts-hd?
I just played a disc in DTS-HD through the 2000 - not sure if the sound was processed by the 2000 or my processor (Integra 9.8). Regardless, the sound was extraordinary.
Dear Fplanner: I timed my 5000es when I loaded a disc; from opening tray to having disc loaded and images on TV was less than 20 seconds...I do have it set up in 'active mode' not standby which reduces the load time; but uses a bit more electricity; not too Green for me...
Hope that answers your question.
Wow! that's pretty quick. Even after doing the firmware update to my 2000, its still almost a minute until I get something, and then about another 3 until I actually see images. Please tell me a little about what this "active" mode is - not sure if mine even has that. Thanks