Sibilance Problem on Digitized LPs

I'm fairly new at all this and am having a problem with excessive sibilance with recorded LPs. Currently not using any sort of DAC either in recording or playback (Is this the whole problem???). I'm using Audacity on a Mac running Leopard to record from a stock Music Hall MMF-5 turntable hooked into a BBE FJB-200 X phono preamp via a long run (25') of left/right RCA cable adapted down to the Mac's audio in pin connector via a Monster Cable RCA-into-stereo-pin-connector cable. These recordings are exported from Audacity into Itunes as either WAV files or AACs and both have the excessive sibilance. I've played around a lot with the level of the recordings but the sibilance problem persists. None of this is present on CDs I've ripped to Itunes with the rare inexplicable exception. Does anyone have any ideas as to how I might remedy this? Thanks.
what kind of cartridge? the first items i would look into, aside from the actual vinyl, is the cartridge and the phono stage. i have done some recording onto my mac with cubase and a presonus firepod, using balanced cables from my ps audio gcph phono stage fed with kimber kcag cables from sumiko blackbird. the results have been very good with little to no sibilance unless the record was not very good in the first place.
Is the sibilance present when you're listening to an LP? Or is this sibilance appearing only after the music is recorded?

I agree that it just sounds like mistracking. Good cartridge alignment and proper tracking force and VTA will alleviate most sibilance problems. The quality of the stylus could also be an issue - is it a new stylus/cartridge?

If you're only experiencing the sibilance after bouncing from Audacity, make sure you aren't using any kind of "mastering" Eq or "maximizing".

Hope that helps!

The cartridge is the stock Goldring one that came with the MMF-5. Don't know the exact model # offhand (1012??) but it's only about 18 months into rather light usage and the LPs played directly thru my amp sound sibilance troubles until they're digitized. One of the prime examples has been on Frank Zappa's "Studio Tan" where the vocalized "S's" border on having a very hard "ch" sound. I've looked in Audacity preferences and can't find anything as "mastering" or "maximizing" although, aside from those verbatim terms, I really wouldn't know what I was looking for. Lots of numbers though! One setting about the third or fourth tab over (Audacity>preferences) looked a little "default bare minimum" to my uneducated eye but, then again, there are so many numbers - sampling rates, etc, etc, that are Swahili to me. There's a tab at the top of the Mac when Audacity is on about 3 or 4 to the right of "Audacity" that has a dropdown menu of what looks to be EQ type settings but they're all greyed out and nothing looks like it was ever chosen/activated.............
Some basic things to check for are:
Samplng rate - you want at least 44.1Khz
word length/bit depth - at least 16 bit.
This is on the way in, of course.

When bouncing down, what are the settings you're using? .WAV files can be any sample rate/bit depth can't they? And AACs are lossy, so you can definitely crunch up the top end by using low bit-rates. You might try doing a full-sized WAV file (CD-quality or better) if you aren't already.

Those checks done, I would check all cables to make sure the signal isn't getting mangled on the way into your computer. 25' is long enough to get some audible loss from the phono pre to your computer input, especially going RCA to 1/8". Loss of high-frequency information is the usual result, though.

Try monitoring the sound from the computer as you record (headphone out jack from the mac?). Do you hear the sibilance on the way in? If so, that long cable would become the #1 suspect for causing signal damage. Perhaps it's the length, the connectors, or some combination of the two.

If those don't cover what's going on, and there's really no extra processing going on (EQ, "mastering" compression, etc), then I'm at a loss. Good luck again!
Agree that you should check your settings in preferences, click on "quality,"
set to 44.1 kHz/16 bit (that's the default). Set the real time sample rate converter and high quality sample rate converter to "high quality." I'm not sure how the dither settings effect things, but you might try experimenting. (Mine are set to; real time, none; high quality, triangle.) Check your file format setting; use a 16 or 32 bit lossless format. I would suggest using AIFF for export. If you export to a lossy format this might be causing the problem.

Be careful not to clip while recording. Keep an eye on the level meter while recording. It will indicate clipping when it occurs, adjust accordingly and rerecord if necessary. Hope this helps.
Try a "de-essing plugin". See