Serious Power Problems with my HPA2

Hello all
I bought a proceed hpa-2 and im having some power issues that i nor anyone else ive ask can answer. The Proceed amp goes thru several checks when you turn main power on and if it does not like what it sees it goes into protection and wont let you turn on standby power. With the amp plugged into just the wall no inputs or spk cables connected (but yes i have tried it with those connected) the amp at my house goes into protection. my volt meter says i have a fairly steady 121.9 to 122.5 vac. if i leave the amp on the floor and run an extension cord to my neighbors house the amp powers on fine every time. I checked his voltage and its in the same range as mine. I have turned off every circuit breaker in my home and ONLY connected the amp and still have the same problem (its a 20 amp circuit) ive called the power company to come out and check the power (they say its fine) and called an electrician to come check house wiring (he says its fine). What am i missing? is there any power device that would solve this problem that can handle the current draw of an hpa-2? Does anyone know anything about the problem im having or can you offer any ideas as to why this is happening?
Please help as im out of ideas
Sounds like the problem is in your amp. I would be curious to know what the voltage is at the end of the long extension cord when plugged into your neighbors house? Have you tried physically bringing the amp to your neighbors house and plugging the amp directly into one of his outlets? I bet you will experience the same problem. Maybe the protection circuit is overly sensitive and when you use a long extension cord you are dropping a few volts in the extension cord which allows your amp to turn on, Bringing the amp to your nieghbors house will prove or disprove this. In any case is sounds as if the amp may need service.
Good idea Gmkowal , but Since it is so heavy, you might also try to use the extension cord on your outlet. Do you have another power cord you can try? Maybe there is a problem there and it was just turned the right way when plugged into the neighbors house? Although you would think that would trip your house breaker. My lights dim a little bit when I power mine on but haven't had any problems except staying up too late to listen. Let us know what you find out.
thanks for your reply although i didnt carry the amp to the neighbors house i did try to run it thru the extension cord at my house and i tried several different power cords with the same results. my concern is that i box this thing up and send it to proceed and it works great there so they send it back to me still broken. still seems strange that it works on the neighbors power.
Have you tried to contact Madrigal yet? If you purchased new from a dealer you might want to contact them also. Have you tried to power the amp from another outlet in the house? I would think the electrician would have checked this, but make sure the ground is good to the house. You can buy outlet checker, I think at Radio Shack or Lowes. Also check the voltage with a load on it and see if it drops. Hope you get to music soon.
I would also check to see if the hot and neutral wires have been reversed at the outlet(s) or at the junction box, or that the ground wire is not properly grounded. European electronics typically have more stringent power safety regulations. If any abnormal condition exists, the equipment won't function. Goodluck.
may not help...but I have an HPA3 and a levinson 334 in my hifi room...all running on the same 20 amp circuit...although conditioned through Tice power supplies...this 1 circuit also has my RP TV and the sub...seems like it would be localized in the amp....

good luck
Try one last thing before you box up your amp and send it away. Jctubes has a valid point about neutral and ground being swapped. I understand your electrician had a look, but nobody is totally infallable. Lord knows there have been a hundred or so times that I have caught myself after a second look. Go to your local hardware store and for maybe $10 pick up an outlet tester. This is not a test light but an outlet tester. The tester usually has 3 small lights on it. If you plug it into your outlet and it is wired correctly a certain sequence of the lights will light. If the outlet is wired incorectly a different sequence will light and the sequence can be decoded to determine exactly what is wired wrong. This inexpensive tool should be in every audiophile's toolbox. I also recommend if it checks ok to plug your amp in to one of the plugs and the tester into the other to test it under a load. I have seen a few instances where resistance in the ground path to an outlet has caused a problem and this can only be found when a load is placed on the circuit so current is drawn. The tester should be able to pick up this problem also. For less than $10 it is worth a try and if you do find something please don't blame your electrician as nobody is perfect and everybody has an off day now and then. Good luck.
Any verdict yet Lross?
Lross, you didn't electrocute yourself messing with this thing did you.