Rega Planet Original

I recently purchased a Rega Planet CD player from a fellow
Audiogon member and noticed that the unit cuts out or skips on all of my CD's. I know that Rega does not employ Error correction circuitry in these units, but geeze! Could it be a bad laser? I hate to have to send in for repair! If I do
who do you recomend for service in the lower 48? Any help would be greatly appreciated.
Have you tried cleaning the laser? I had a Planet for many years. I cleaned it with a Q-tip and rubbing alcohol every few years. Maybe I was lucky, but that cleared up any read problems for me.
My original Planet skipped now and then and it seem to a rsponse to in-room, system-generated vibrations. If you can isolate it from room-source and shelf-source vibrations it might help.
Cleaning the lens might also help.
Agree with Jgiacalo - these players have no isolation - will skip if they are picking up anything in terms of bass feeding back into themselves.Try isolating it and see if the problems go away - simple experiment is to buy/borrow some longer cables and move the player away from your other equipment - if the skipping disappears - then you know what the problem is.For this test the quality of the connecting cable is of no importance - cheaapies will work just fine.
These are still outrageously musical players.
You'll probably find that you need to replace the laser. I did. The originals are getting long in the tooth and the lasers are starting to crap out. Rega did not give me a satisfactory answer on replacement. I could recommend a shop or two to do the replacement but it's probably going to set you back three or four hundred bucks.