Proton 550 Intergrated Amp

I just picked up one of these cheap and I understand that this amp paralelled some of the NAD stuff. Unfortunately, after receiveing the unit, it powers on but the protect light is on. Is there a simple way to get this amp out of the protect mode and render it usable as amp appears clean. Also would appreciate any info on this integated and the Proton 450 matching tuner, Thanks
Proton factory service in Calif. is really good. Give them a call.
The protection lamp remaining "on" and in the absence of the delayed sound of the relay "click" means that there is DC present at the output of the amp. The protection relay is protecting your speakers from the rail voltage that is passing through the bad outputs. If this protection were not there, your speakers would quickly become literally toast and might catch fire. This is a relativly easy fix for any competant tech. If you find one, tell him to replace the bad transistors as a set. In otherwords if one of a pair is bad, replace both together. If there are a parallel push pull set in that one side, replace all four. The same goes if the short backed up into the drivers. Last but not least, have him remount all the transistors with fresh thermal greas on the heatsinks, good or bad this is a must as this particular amp generates a lot of heat and the white grease is usually dried out which might of caused the problem in the first place. Have this done as I have said and this can be a real nice set with gobs of dynamic headroom that other sets of the same wattage can only wish for. The repair is worth it.