Progess. scan pic not as sharp as interlaced-Why?

I have a Toshiba 65HDX82 rear projection tv(high def) & a Marantz 6200 DVD player w/progessive scan. When progess. scan is turned on in DVD menu, the picture is not as "sharp" as when prog. scan is turned off. I used a good component cable; the DVD player is switched to "component"; & is plugged into HD Component inputs on tv. I don't understand this. I thought prog. scan was a much better picture? I traded in a Marantz 3100 dvd player to get the 6200. I'm beginning to think I didn't have to do that. Help!! - Dave
Progressive scan is intended to appear more "film-like" and to that end it softens the picture somehwat in an attempt to reduce the appearance of the scan lines. Some regard this as a "better" picture. The size of your screen magnifies the scan line issue. You won't have the crystal clear HD picture you see on your HD broadcasts because the player itself isn't HD. However, although I'm not familiar with your Marantz DVD player, you should have the ability to select varying degrees of sharpness/softness generated by the player. I have this feature on my five year old non-progressive scan Panasonic DVD player. It sounds like you have things connected properly.
The line doubler 3/2 pull down in your Toshiba 65HDX82 rear projection tv(high def)is better than the DVD player. Running your player interlaced w/ component connections will aid for for a more filmlike smoother picture.

Your TV is already doing the work, running progressive on the player the 2 line doublers try to cancel one another out!

My cousin has the same Toshiba TV, along w/ a Toshiba SD-9200 DVD player. When watching "Armagedon" for example in progressive it tore Liz Tyler's face appart!!! Back to interlaced & she was once again easy on the eyes!

Nothing wrong, Toshiba's TV just has the upper hand!

Good luck :)~

Nope you didn't need to upgrade players, a Non-Progressive Dvd Player would do just fine w/ your set! As long as it has component video out connections.
There is also no way to turn off the internal line doubler on the Toshiba, not that you'd really want too?