Proceed HPA2 blinking.

In need of help.

I have a Proceed HPA2 amplifier.
The power indicator light (yellow color) is
The standby light (red color) is completely off.
There is no power going to the speakers
I had the amplifier directly connected to the wall.

I connected the amplifier to another outlet and I
have the same problem.

What could be and what to do?

I would appreciate any help.

Got this from the manual :

The power indicator light (above the small power button, below the large
standby button) is normally either on or off, indicating whether AC power
is being supplied to the amplifier. It will blink on and off if the amplifier’s
protection circuitry has been engaged (shutting the amp off to protect itself
and/or your loudspeakers). In the unlikely event that you see the power
indicator blinking, disconnect the amplifier from AC power and call your
dealer for assistance in solving the problem.
The standby indicator light (above the large standby button) glows either
amber or red, depending on the operational status of your amplifier. Amber
indicates that the amplifier is on and ready to be used. When the indicator
light is glowing red, the unit is in standby. If the standby indicator light is
completely off, the amplifier is not receiving power. Check your AC connections
and the rear-panel AC fuse
Riley804: Thanks.

I called them, busy phone all day for the last 2 days.
Holiday vacation? or please do not bother us?

This amplifier was causing a moderate "click" to my speakers
when it was turn on but this problem was on and off.

The day before it went off, after I turn it on, at the beginnig, it was causing a little loudly interrupted noise to the speakers for a few seconds . The noise was not hummm

Any ideas what could be the problem ?