Problems with my remote

I have a Audio Note CD2.1x cdp and all of a sudden the remote quit working. I thought the batteries went bad so I swapped them out for ones that I knew were good to no avail. My question is how do I know its the remote and not the cdp? Anyway of diagnosing this?
Have you tryed re-booting the CDP? Unplug it for 1-2 minutes and press each button on the face plate when it w/o power. That drains any capacitance in the unit then re-plug it in. I have had equipment do that and aanything with a processor such as a CDP can need re-booting from time to time. I wonder if Bill Gates has to unplug his toaster from time to time?
Thanks for the suggestion Theo I tried that to no avail. I think I'll take the top off and see If I see anything suspicious.
Well I got it to work. I actually "banged" it on both ends and it started to work again. Maybe something inside came loose and got lodged in the pathway of the signal? Go figure.
Banged on what the CDP or the remote? Eitherway it's working, that's is a good thing.
Turn off all other remote control devices in your house. And your problem will disapear. find the device in question and leave it playing. This worked for me. Write back. Mike

I had an almost similar problem with my Simaudio remote operating the cd player, until I found out with a lot of rebooting (I'm a slow learner !)what I was doing wrong.

For instance, the cd player would not power on with the remote if the last time I closed it was with the power button on the unit itself. So since I've forced myself to use exclusively the remote to operate the unit, I didn't experience any more problems.