Problems with Lutron Light Dimmers causing a Buzz

I am having a problem with the Lutron light dimmers in my home causing a BUZZ in my adio system. It never was that much of a issue or problem until i sold my SOUNDLAB A-3'S and i am now running a pair of JBL 250ti's which are much more efficeint. We built our home about 2 years ago and we have approximately 12-15 of these Lutron Dimmers placed throughout our home and i have to make sure that every one of them are turned completely off, otherwise i will have a horrible buzz in my speakers that was never even noticeable in my previous A-3's. I do have dedicated lines going to all of my gear, but i do not have any kind of power conditioning or surge protection due to the fact that i have always been told that it destroys the sound and quality of my system.
My system consists of the following:


Do any of you fellow audiophiles have any solutions to this problem? i really would like to avoid removing my dimmers, due to having so many, plus i love the effect of them in our home. Any help or suggestions would be greatly appreciated.
I have an idea that may or may not help.

The big change in electrical here is the Soundlab A3’s power supply which plugs into the wall, providing an additional ground plane.

The Tube Research is typically not grounded, (my GT 400’s were not). However, the back plate on A3 Soundlabs tie the third pin (ground) of the IEC, and the amps neutral to the power supply.

It might be possible that this additional ground plane was scraping off noise and hum. To test, use a length of ordinary zip cord between true ground and various pieces in your system. The third pin of the wall plug is ideal and may be tested by hooking up ONLY the ground pin and then touching it to the various components.

If you have any doubt at all as to which pin is ground or lack experience with electrical, don’t try this. I don’t want to be responsible for anyone getting hurt.
Excellent idea from Albert but as his final note indicates, playing with raw power, bare wires, touching chassis, etc., just make sure you use the correct pin as he states. Since you say every dimmer in the house must be off, I would try one or two different dimmer brands in one location and see if you have any luck. If you find one that works, then perhaps replace one at a time or just those that would typically be on at the time of music playing.
Hey Shutterbug, Blueswan here. Bought your A3s and love them! I know Tube Research doesn't recommend it, but you might want to consider a power conditioner. I use a Tara Labs AD/10B. Everything is plugged into it. (I can plug in and run a vacuum cleaner in my listening room and the TV won't show a single interference line.) This approach allows you to have a single ground for the entire system, the power cord from the conditioner to the wall.
I have Lutron "Symphony Series" dimmers in my listening room, and I had the same annoying problem. If your situation is like mine, it's reasonably likely one of your interconnect cables have an anomoly. Ultimately, it came down to a poor connection on one of my balanced connections. I replaced the set, and the problem was resolved. Hopefully you will be able to remedy your situation as easily.

Good Luck.
I tried changing to some new IC's because i had some around but no luck with that. i would like to try some of the other suggestions but i am not sure exactly what to do.??
I'm also using the Lutron dimmers in my den where the audio systems is set up, but without the problems your experiencing - at leaste in the den. The "big" system in the den is being fed power totally by dedicated lines, separate and apart from the rest of the house wiring. In the kitchen however, the clock-radio hums whenever the Lutron dimmers in the den are turned on. Since I really don't care about this situation, I've never tried to correct it. Since you already have dedicated lines, I wonder if they are being run too close to the wiring that feeds your lights... If possible, try running power from the breaker box to your equipment along a different path. You may find that this solves the problem. Good luck! Ken