Problems with Bluesound Vault and PC app finding Node2 that are wireless


Does anyone else have this problem?   My PC is hardwire LAN to the Bluesound Vault2 and the wireless router.   The two Bluesound Node 2's are wireless.   About 50% of the time, the Bluesound App on the PC cannot find one or both of the nodes.    I have the same problem with Roon as well.   It is very frustrating but I don't see anyway out of this.
Previewspatialking
Is it a wireless signal strength issue? Move one of the Node2's into closer proximity to the wireless access point/router and see if the behavior changes. If so, you might be able to get a wireless access point, or wireless router, with great range. Or you could look into a mesh network link the Linksys Velop.

However, before investing much time, or any money, move one or both of the nodes to see if it's just a matter of wireless signal strength.
Actually, I just bought a new NightHawk router for that reason plus a few others.   It could be a signal strength problem, I will check that tomorrow.
Hell, I have problems with my two Nodes dropping off as yours do, and I am totally Ethernet.  I doubt it’s your router.  
If you can't run a wire to the Nodes, here are a few things to look at:

- A better router
- A wireless repeater and/or Wireless Access Point
- Does your cable modem also have a wireless router?  If so, you might try turning it off.  If the devices connect to a different network than the one your PC is on, you won't "see" them.

I have two WAPs, one in my living room and one in my office and a repeater in my bedroom which is the furthest from my router and all my wireless devices stay connected.  My Comcast modem has a wireless router and I stay off that network.  There are speed test and network test apps you can run on your phone that will give you an idea of how good your wireless network is performing.
The repeater is an interesting idea, the others I have already tried.  I got a new router, recommended by Roon to solve this problem.   It was better, yes, but didn't solve it.   The ComCast modem was installed in Bridge mode, so that wireless part is not operational.      I'll check signal strength tonight.

mahler123 - I am glad I am not the only one.  I have suspected for some time now that this problem is indemic to BlueSound Vault2's and Node2's.  Well, we can only hope that they will fix it.   Frankly, this is such a major problem, I wish I didn't buy the stuff and bought something else instead.  Dang, my analog LP's are faster to get into play than this stuff.  
Have you tried sending a support request to the Bluesound tech folks? I had a similar problem with the iPhone and iPad apps occasionally not finding my Powernode, and the techs were very helpful in getting it resolved. They did a remote access to my system and made a few changes to my wireless router settings.  
I, too, am having issues with Bluesound.
Spotify skips, Deezer repeats.
They have been good at responding to my requests, but after some update in September, I have been having nothing but problems-none of which is resolved.
Please do open a ticket. You can do it on the 'Help' tab on the BS app.
Before you do that, just make sure you are on the latest OS for both the Nodes and App. You can find that on the 'Settings' tab.
HTH
Bob
I have made multiple calls to customer service over the holiday weeks and they haven’t answered.  I am off tomorrow and will try one last time but I’m ready to move on from Bluesound.  Am thinking of Bryston BDP 2 or 3, since I have a Bryston DAC
I have both the Vault2 and Node2 and can't remember it EVER dropping out . I'm sorry you gentlemen are having that issue. That would be frustrating.
@Mahler,
You have to put in a ticket through the app Help tab. They get back very quickly.
B
I have not had any issues with my BlueSound Node 2 dropping out, or any of my other streaming devices (Roku, Oppo, Marantz, etc.) since I upgraded my router a little over a year ago.  I spent about $200 on the router and that fixed a lot of issues I'd been having, other than devices sometimes not seeing each other because they auto-connected to a different SSID after a power or internet outage.  I can stream 4K content to the same location where my Node 2 is sitting.  It could be your Node, but I'd look elsewhere first.
@bubba12 & big_greg - tell us about your system - is it wireless, hardwire LAN?  what router are you using?   What is your signal strength if you are wireless?   Are yo on a Windows 10 Box, Apple, or Lynx?

I just noticed that a new upgrade is available as of today for the Node2.  I'll install that and let you all know the results. 

I have filed help tickets about this matter before and BS has been pretty quick on answering.   They were pretty slow on responses over the holidays, though.  

I hate to say this but my old Logitech Squeezebox, which has to be at least 8 to 10 years old, never has a problem.   It is on the network every single time and never loses its connection to the wireless router.  It does simply stop playing every now and then, as if someone pushed the pause button, but it never loses the network.
@spatialking I have D-Link DIR-890LR router. The only thing in my house that is wired is my PC. I have a WAP in my office which is in the next room and another WAP in my living room where my main system is. It’s not very far from the router, maybe 20 feet. I have the repeater on the other side of the house in my bedroom. My laptops, tablets, TV, AVP, Oppos, BlueSounds, Roku, etc. all are wireless.

Signal strength is about -35 to -45 in all the locations where I have wireless devices. My PC is running Win 10 Pro.

I just picked up a used Node 2 and set it up in my bedroom last night and was listening to Sgt. Peppers MQA on Tidal with no issues.
I just did the newest update today.  Usually when they offer a new update soon after a previous one it is to fix something that the previous update broke, but this made things worse 
I finally got the Bluesound app to find the missing Node, did a upgrade, rebooting everything, and for now, it seems to be working.   

One thing I did discover, the hard way of course, is after an upgrade one has to do a manual warm reboot of the system via the diagnostics menu.   Simply cycling power is not sufficient.  

However, my old Logitech Squeezebox Touch fires right up after every power fluctuation, glitch, or whatever.   It simply starts playing right where it left off, as if it was an analog FM tuner and that has at least 9 year old wireless technology in it.   Gotta love it.
Mine won’t even do factory resets, and I haven’t had a call returned since before XMass.  I am using my Oppo players and Audirvana with my Mac to control my NAS.  I’m done with Bluesound 
@Mahler123 - yes, I understand.   If I could return all this stuff and get full credit, I'd do it and buy something more robust.   But, I am reluctant to take a loss on it and, so far, Bluesound has been responsive and is working on the problem.  

The factory reset is a pin you push in the back of the unit - if it doesn't work, I'd say you have a warranty problem.  
If your PC have windows software download it can be a very big help to the wireless router too.
I have been having issues with my Bluesound App/Nodes for a few months.
Today, Bluesound emailed me and said they replicated the issue and hope to issue an upgrade soon.
I have to say, they have been very patient and vigilant in trying to correct this problem. 
If there is one thing that they should work on, it is in allowing you to contact them. For me, the best way is through the app. Click on Help and then click on Support Request. This sends the logs as well as your request for help. They always got back to me within one day.
@Mahler, 
You have to remove the power cord, then hold down the button and re-insert the power cord. Hold for about 30 seconds until the light changes color.-If I remember correctly.
Bpb
I finally called the district sales manager.  My dealer—now out of business—had given me his number when I first bought it and had issues 3 years ago.  I forwarded my emails with Product Support, which stopped abruptly 10 days ago when they didn’t schedule a home phone session with me after I had done all the steps that they required to be granted one.  He was fairly appalled and said he would get back to me
@mahler, 
Wow, that sounds bad. My interactions with Bluesound have been stellar, especially considering I bought my Nodes second hand.
I know there are 2 techs, one is named Maya. I'll try to see if I can get her to look at your problem.
Bob
Maya is the one that was blowing me off
Just finished a 90 minute service call.  Everything for now.  Several interesting findings.
1) Players wouldn’t do factory resets because the latest update was “stuck” within them.  All 3 players had to be force fed the firmware by the tech (Aitei).  The update was for Airplay on the 2i and allowing Alexa, neither of which effects me, but that’s apparently beside the point...they recommended that the players not be grouped during updates, and I had them show me how to do them by usb.
2) My NAS wasn’t being recognized because apparently a previous update from Bluesound changed the settings on the NAS.  They had no idea why or how to prevent this again.
3) my follow up emails were being ignored apparently because they automatically go to the back of the queue.  In other words, when Maya asked, “what time is good for a call” and I answered and hit return,  then it goes to the back.  Apparently you are supposed to answer by starting a whole new email chain and refer to the original ticket number.
fwiw, when I set up my NAS months ago, I hired an IT pro, and we had a conference call with Bluesound to enable us to transfer the Vault contents to the NAS, and he said that Bluesound uses protocols on file sharing that are out of the mainstream IT world.  I would add their method of handling customer emails to that list
@mahler,
That's weird. I just replied to their emails and got answers back the next day or so.
I, too, found out that the players should be ungrouped before update after getting the same error. That is something they should let people know about.
Did the reset fix the problem?
B
everything seems to be working.  Keeping the fingers crossed.
the tech said they have had a big increase in sales around the holiday and thus they are swamped...makes me wonder if the 2i is having some bugs...
I have the 2i and haven't had any problems with connections or updates. SMB  is the file sharing  protocol they use which has been around since the 1980's and is still widely used in small networks. 
the players should be ungrouped before update

Actually, the update should be smart enough to ungroup the players, update them, then regroup what it found originally.   To me, this seems like an obvious common sense thing to do.

As for my system, the recent 1.6 upgrade made the Nodes disappear from the network again.    So, I am doing the reboot, reboot, reboot thing until they reappear.

Spatial

Did you do the update from usb drives, Ethernet, or WiFi?
That’s really discouraging.
I did my update via Wifi.
I needed to reset one of my Nodes-due to them being grouped, and then it accepted the update. No problem with them disappearing. 
Only Spotify gives me trouble-but now that I got a Quobuz trial, I might just go back to the free version. Too bad, as I like the 'Discovery' tab. It always offers great selections that I wouldn't have thought of.
B
I upgraded from Ethernet and I was able to get the system up and running on the third reboot.   At least I didn't have to reboot my PC this time.  

I believe the catch here is starting Roon on the PC after the reboot and the Node and Vault has logged onto the network.  Roon looks for players at boot up but I don't believe it looks for them afterwards.    Maybe it does and it just doesn't work on my system.  

I normally leaving Roon running in the background all the time so it is easy to log on with my cell phone and control the system from there.    The PC is at the other end of the house, so trying to work the system from that is not practical.   Next time there is an update, I will close Roon on the PC, do the update, then reboot the Node and Vault, then restart Roon and see it that works the first time. 

Clearly, Digital Audio via Computer is still uncharted territory.
Update - after living with the recent Bluesound and Roon updates, the entire system appears to be far more stable than before.  

Of course, now that I posted this, it's a given the entire system will collapse......
I have the node and feel the key issue is that it has a very weak WiFi reception. My Apple TV and MacBook can pick up a signal and stream video when the node often can’t find the signal or it is very weak with drop outs. Once I moved to an Ethernet connection most issues were resolved. But I wouldn’t have purchased the node to begin with if I knew about this problem. 
I agree, I would not have purchased the system either.   The Bryston or Wyred4Sound are much better systems. although a lot more money.   The fact is, I had to buy a system for the cabin and I went with Bryston rather than another Vault 2.  I'd sell what I have if I didn't have to take such a loss on it.
Just make sure that you PC contain the latest free software download for Windows and update your Router, It should work fine :)