Problem with USB audio

About a week ago, when I tried to play music using my Asus A8 laptop and Benchmark DAC1 USB, music would play for a few seconds, and then drop out completely after a sudden, unpleasant noise, regardless of whether I am doing anything with the laptop or not.

I used my Asus laptop, which was less than two years old, to feed data to the Benchmark DAC1 USB via a USB cable. Before last week, I had no problem with USB audio at all - even when I am doing many things on my laptop at the same time. I have tried an IBM PC and a Macbook Pro after the problem arose, and they both worked fine, so the DAC1 USB and the USB cable are cleared. I use Foobar 2000 v0.9.5.6; however, I also tried Windows Media Player, with the same result - after a few seconds of music, the music stopped completely while the WMP indicates the music was still playing (like Foobar did).

So, apparently there's something my laptop was doing wrong, does anyone know what? Any comment/advice is greatly appreciated!
Make sure that the USB port on your computer is a good one. Try them all.

Also, give the player high priority - realtime or highest.

If you are running any other USB devices, this will screw things up. Remove them and try again. You may have a conflict in interrupt servicing.

Steve N.
Empirical Audio
As usual,good advice Steve.Who would think there would be differences in USB ports???Nothing is easy[Jethro Tull]....
It is a documented and well known fact that there are differences in USB ports on various computers - Macs and PC alike. Try them all as Steve says.

L.D. Moore
Ultra Fi
Asus has a pretty good forum and I just did a search for "A8 USB problems" - I got a few hits and one or two sounded similar to the problem you are having. One guess having messed with this stuff for years is to check the Asus download site for updates to the USB and make sure you update the chipset drivers. Do you know what version of the A8 you have? I am guessing you are running Win XP, What service pack are you running? Did you upgrade to SP3 lately? I had a few machines go whack after the SP3 install.

I assume the Benchmark has a driver ... any updates to that? Beware of any USB devices that install themselves. If Windows didn’t prompt you for a driver for the Benchmark DAC and you didn’t use the driver Benchmark provided - the operating system could have installed the wrong device driver. (Check the Hardware Manager)

Consider contacting Asus ... I have had pretty good luck with them in the past. My guess is it's an issue with the USB/Chipset driver. I have seen patches for this on various laptop brands ... it's not just an Asus issue. Keep in mind XP is a pretty old OS so new devices tend to confuse it ... that’s why the need for all the driver updates. Not knowing your comfort level; if you’re relatively inexperienced with computer hardware try getting Asus to give you a hand. Don’t start installing new drivers with your fingers crossed – that can create problems. Make a list of everything you have tried … write down the OS, service pack level, make, model and serial number of the laptop. If you know how : create restore points before each change. Restore points have saved me a few times in the past.

Hope this gave you a few ideas …
Horseface - makes me cringe to call you that - the Benchmark and Empirical Audio products use the native windows drivers. There is no driver to load. No ASIO to load.

However, there are still some hurdles, namely kmixer on XP. To bypass this, either unmap the device or use Kernel Streaming. It is bit-perfect with this. Vista is bit-perfect with these devices also.

Steve N.
During my conversation with a Benchmark engineer, I was told to stop processes that I don't use. I googled the ones that seem to be taking more resources, but read that they shouldn't be removed. I did give all the priority of Foobar "7" (1-7, I assume 7 is highest). The good news is, when I'm NOT running anything else AND NOT moving the mouse, USB audio works. The bad news is, it is impractical.
Does anyone think upgrading the RAM from 2G to 4G will solve this problem?