Problem with loud buzzing noise on amplifier

My Audio Refinement integrated amplifier occasionally makes a loud electric buzzing sound usually 10 to 15 minutes after it has been turned on. The sound becomes louder and more frequent over time. Although it eventually burned the transistors, which were replaced, the noise is still occuring.

Has anyone experienced this problem or have any advice on what may be causing it?
I think buzzing is usually the transformer. That's assuming the buzz is coming from the amp, not the speakers. Hope you get some tips from the more tech savvy here.
Is this a mechanical transformer issue, or do you hear the buzzing through the speakers? What must be determined is whether or not the problem is coming from the preamp/amp itself, or is it a radiated noise issue. If it's a noise radiation issue, a high quality power line isolator may help as the noise could be coming in through the power line. If you have dimmers on the A.C.circuit that also controls room lighting, that could also be an issue. If this is internal to the amp/preamp it could be caused by a problem with the power supply. You did not say if the noise was coming from both your speakers or just one channel. You also did not say if the output transistors on both channels were replaced or just one channel.
Thank you very much for responding. With regards to the noise, it appears to be coming from the speakers, however we're pretty sure the problem is with the amp/preamp because we connected the amp to another sound system with different components and the noise continued to occur. Also, the output transitors were replaced only on one channel since they were functioning properly on the other channel.
Sounds like it needs to go back to Audio Plus Services.
This sounds like the amplifier could be oscillating. Its not likely to be a transformer problem- that would not damage output transistors.

I would get the amplifier to a reliable service department or the manufacturer. If you don't attend to it, the transistors could well fail again.

If there really is an oscillation, its at a very high (inaudible) frequency, and the buzz you hear is merely an artifact. An oscillation like this can damage output sections as it forces the output transistors to switch very quickly. This can overheat them quite easily.