Pro-ject Debut 3 problem with unbalanced sound

Hi guys,
I recently got a cartridge upgrade for my Pro-ject Debut 3/SB, replacing the standard Ortofon OM5e with an Ortofon 2M Red. I got it installed at my local hi-fi place and got it home to find that the right channel was very quiet, at almost half the volume of the left. I took it back and asked them to fix it up, and they said that the anti-skate weight wasn't put on properly, so they supposedly fixed it. I've got it home now and played a few records and noticed that nothing had changed, the right channel was still lower than the left. I hooked it up to my computer to make sure I wasn't hearing things, and the RMS scale equaliser thing (or whatever you call it) was reading a much bigger signal on the left.

Does anyone have an idea on what I could try and do to fix this? I really don't want to take it back to the hi-fi place since they supposedly fixed it twice, but never did.

Thanks for reading, hope you can help

Did you plug it directly into the puter? If so, either
a) there's something wrong with yr cable (unlikely) OR
b) there's something wrong with the cartridge.
I think another visit to the hi-fi place is in the air!
The cart is messed up and you need a replacement. the place that sold it to you needs to take it back and give you a new cart.
agree with elizbeth.
You could switch the left and right cart connections, just to make sure it's the cart, before you take it back.
I agree with all the comments above, but would add that if they couldn't even get the anti-skate right, be suspicious of the cartridge alignment, too, which can contribute to imbalance.