Plinius 8200 mk2, really low volume!!


I just put together a very basic, modest 2 channel vinyl system like this:

Plinius 8200 mk2
Rega P5/ Ortofon Blue mm
Vandersteen 1Ci

I am using the built in phono section, and I don't think this system plays very loud at all, as a matter of fact I know it doesn't! I have tried using both gain sections with no noticeable difference in volume. Am I missing something? The Vandersteens are pretty efficient speakers and the Plinius has about 175 watts, I thought it would play much louder--I'm not talking about concert level volumes but this system sound like the sound just drops out of the front of the speakers, no punch. Is it possible there is something wrong with the Plinius integrated? Thank you in advance for your thoughts---

                                                                            Bill
itsalldark
If the above doesn’t work, try a Belles Aria integrated with built in phono.  Great synergy with the Vandersteen.  Best.....
Check the " processor " switch on the back of the amp.
I figured it out, I have never owned a cart with a replaceable stylus before--it wasn't fully snapped into place!!!! thanks everyone, once I did that the system sounds very nice.
I'm glad you figured out what the problem was. Your Plinius will definitely sound good and drive any speaker. I've had several of the Plinius Integrated amps and was always very happy with them.
That's pretty much exactly the system I would suggest for friends who aren't audiophiles and don't want to spend a million dollars.