Paranoid on Tube Amp Install

Can speakers cause a tube amp to catch fire? The last tube amp in my system 3 years ago caught fire (just 2 minutes after installing). I always assumed the amp was damaged in shipping. I just ordered another tube amp and I'm both excited and nervous about installing. The speakers are Acoustat 3300 electrostatics and I've been using ss amps since without issue. I really don't want to sit in my chair again, frozen in shock, as I watch a blue flame.

Thanks for any feedback,

Check the tubes and the fuse. Ensure you have stable AC as well.

My tube amp blew a fuse because a faulty driver tube. I replaced the orginal fuse with upgraded HiFi fuses as well as new drivers and power tubes.
Think of it this way. You have been stuck by lightning once. What are the odds it will happen again? Most gear, tube amps included, don't catch on fire. Obviously they can as you well know, but in my 30 years in this hobby (including some real hack mods in the 80's), I have never had a piece catch on fire. Don't get me wrong, there was plenty of smoke a couple of times, but never fire. Bias it up outside of your system and let it run in for an hour before you risk you speakers.
Bias it up outside of your system and let it run in for an hour before you risk you speakers.
4est (Threads | Answers)

All tube amps I am familiar with should never be powered up without a load connected (ie speakers).
And might want to get you a long-handled broomstick to push the power button on. Wood, preferrably.
Speakers cannot cause any amp to catch fire. I've been in the amp business in one form or another (worked in serveal service centers and then in manufacturing) for 37 years. So far I have yet to see an amplifier catch fire, tube or solid state. That's... rare.
There are very few tube amps that cannot be on w/o a load and no signal. Maybe I am weird, but I have always turned on my tubes amps unconnected initially to check bias.

In either event, the speakers weren't the problem, and tube amps don't generally start on fire. Here's hoping you have a better experience with tubes. I rather like them...
Simmonsg- I would check w the amp's maker before I turned it on w/o a load if it were MY amp. Many (can't say most, cause I don't remember, but it was more than just a few) of the tube amp manuals I have read say never to power on w/o a load.
I agree with Swampwalker I was always under the impression to never power on a tube amp without a load;anyone know for sure or are there ones in which you can run unloaded?
Agree with Swampwalker, you most likely will need a load before powering up your tube amp.

You can buy a high power resistor to be used as a dummy load if you don't want to connect your speakers to the amp during biasing.
You can power a tube amp without a load but once you send a signal from the preamp to the unloaded tube amp say bye bye to the amplifiers power transformers. As everyone has stated dont power up a tube amplifier without load as a rule