OSX Yosemite Upgrade and DAC Malfunction

Hi, folks. I "upgraded" my MacAir to OSX Yosemite on Tuesday and now my DAC (Esoteric K-03) won't work properly. Whether on iTunes, Amarra or Audirvana, I get about 15 seconds in before the sound begins to warble, distort, chatter and finally stop altogether. I'm assuming it's a driver issue (there hasn't been an updated Mac driver on Esoteric's website since 2011), but I'm wondering if anyone else has had this problem and if there are any creative fixes anyone has discovered. Thanks!
Sorry to hear the problem, Hsimon. I've delayed installing Yosemite and no real
help for you. Have you tried calling Esoteric OR posting on one of the MBA
boards? Hope you get some input more useful than mine. I'll be following this
topic. Thanks for posting the question. BTW - pretty certain I saw a recent post
where someone else THOUGHT installation of Yosemite caused a problem with
their DAC. Seems like they got things sorted but don't recall details.
Yosemite has caused a lot of need to log-on problems at web sites I regular visit. The GUI appears very different and the download and installation to a long time on my iMac, so it must have been a major redesign.

I feel lucky. I installed Yosemite on my 2012 Mac Mini and I have had no issues with my Esoteric D-07. iTunes is all I use.
Thanks for the responses, folks. The answer in my case was to switch the USB setting on the Esoteric from HS (High-speed) 2 to HS-1, which bypasses the clock single on the DAC and reverts from asynchronous to synchronous mode. I haven't listened super-carefully yet (or to anything above 44.1), but on casual listening to low-rez files, I'm not hearing any difference.

Another issue (gotta love Apple!) is that with the Yosemite upgrade, the Esoteric high-rez player (downloadable at http://www.esoteric-usa.com/HR-Audioplayer.php) can't find the K-03 as the output device, despite all the settings being correct. Sigh . . .
Just installed Yosemite this morning on my "late 2012" Mac Mini. I'm now listening to iTunes Radio (Allman Brothers Band .... by the way, tonight at the Beacon Theater in NYC .... their last concert) via my Audioengine D1 DAC and A5 speakers. Although I'm still keeping my fingers crossed ..... no problems at all. And, is it just me, or does Safari now seem faster than it was with Mavericks ? Bravo Apple .... nice update !
A bit off topic now that I don't have a general problem with Yosemite. I think the reason I need to log on to web sites that previously didn't require it is a change in the Clear History command I use when leaving Safari. It now reads clear history and web site data, so I suspect it clears cookies as well. 1Password fills in everything when I click on the log-in box.

Had the same problem with my K-01 on HS-2. Works fine on HS-1. I presume a new driver update will come shortly?
Has anyone had any further experience or information regarding the HS-2 incompatibilities? . I have tried to contact Esoteric and it now goes to Integra Home theater and can I just say they are less than helpful, in fact they are totally unaware that they even cover the products.