Optical Digital Audio Cable - Loose Fit?

My Panasonic Plasma TV has a Optical Digital Audio Plug for connecting to the Surround Sound Processor. However, the cable is a loose fit at both the TV and the Processor.
Any suggestions? Thank You.
Try a different cable if it is loose on both ends.

First off... is the sound ok despite the loose fit?

if not..
buy a better TOS cable...

run directly into the receiver from the source instead. Straight out from the cable box, DVD, etc.

I went ahead and ran a Walmart TOS cable from the FIOS HD box into my Panic sonic Plasma I just got the other day. After a few days the audio sync'd up pretty nicely.

Both my cable box and BDP 83 run HDMI into the plasma set.

I just watched "From Paris with Love" and apparently need to reset my oppo to output multi ch via coax instead of via HDMI, But I did notice that configured as is there was scant little diffs from sending the audio into the set via HDMI, and out of it via the TOS link into the reciever... versus going directly out of the Oppo via a XV2 cable into the Receiver. Almost indistinguishable diffs.

I did notice too, my multi ch light on the receiver did not light up using the Oppo in either configuration. Telling me as I said, it looks like some more fiddling is needed with the BDP 83.

The multi ch light does light up when the cable box is on a multi ch audio delivering channel though.

you might want to set the sampling freq as well in the Panny. they give you 3 choices. Two of which 44.1K & 48K ought to be good for you.

You can also add a small piece of heat shrink to the end of the optical cable fitting and then once shrunk, trim off the excess to make for a tighter fit.

But if it's playing OK I'd leave it alone and find something else to worry about.