New system with periodic sound dropouts

Within the last 2 months I've gotten new speakers (Monitor Audio Gold 300), pre-amp (Primare Pre32) and power amp (Primare A32).  Since setting it up, there are times when my DAC loses the signal and no music plays for 1 - 2 seconds.  Other times music plays flawlessly with no dropouts.  I just tested the outlet where my gear is plugged in and got voltage readings between 123.5 - 125.9 (but I only had one drop out and that was earlier in the day).  My subdivision is less than 5 years old and all of our utilities are underground.  I've been considering an AC conditioner or regenerator. Do I really need one?  If power isn't the problem does anyone have an idea as to why my DAC sometimes loses the music signal?
To clarify a bit more, dropouts never happen when listening to the CDP.  They only occur when listening to music servers (JRiver Media Center or Signalyst HQ Player) on my less than 2 year old Windows 10 computer. 
Ahhh, wait, are you wireless? :)

Wifi is awful in conjested areas. If you use Android, use Wi-Fi analyzer to find free channels. Also, usually 5G is less cluttered.
Yes, I think Erik is on to it, so network (wireless or wired).
As with many computer-related issues there are countless possible causes, but I doubt that power quality is a factor in this case.

If a wireless link is involved, as suggested above interference on the channel that is being used is certainly a possibility.

What specific make and model is the computer? Does it have a mechanical hard drive or an SSD? Is the music stored on the internal drive that is utilized by Windows and the server program, or on a second internal drive, or on an external drive?

Also, what anti-virus program are you using, and have you tried temporarily disabling it? Some anti-virus programs can slow a computer significantly.

Also, if you already haven't, under the Start icon/Settings/Update and Security/Advanced Options/Choose How Updates are Delivered, change the default setting of "on" to "off." Otherwise, as stated on that page, "your PC may also send parts of previously downloaded Windows updates and apps to PCs on your local network, or PCs ON THE INTERNET" [emphasis added], which among other conceivable issues may intermittently slow down your computer.

Finally, your reference to "the last 2 months" brings to mind that the major "Anniversary Update" to Windows 10 was probably automatically installed in your computer during the month of August.  If the computer and DAC combo was working properly prior to that time the Anniversary Update, which caused a variety of problems for many Windows 10 users, may have been a factor.

-- Al
Latency and dropout... common when using Windows networking for music servers. It's the time it takes to buffer fill and has nothing to do with the electricity in the wall.
My computer is a Dell Inspiron 3847 desktop connected wirelessly to AT&T’s network. The Microsoft Windows Update came through 9/30/2016. All music is stored on the internal hard drive.  Forgot to mention I also have a new 4 foot usb cable. Never had problems with the old 1 meter cable. Switching back to see if there’s a difference.
Ahhhh, hahaha.

I doubt seriously that it’s your USB cable. More likely it is your wireless connection.

Since all your music is local, one thing to try, turn your networking OFF. Windows and apps sometimes stutter when the network connection gets iffy, and this can affect ALL running applications. Another thing to turn off is any anti-virus canners. I normally tell AV to exclude music directories from scanning.

Another reason why I’m on Linux, but even then, Firefox for instance really sucks when network gets funky.


One other thing to try, if you are using any other USB devices, unplug them.


Thanks for the advice, Erik.  I have no other USB devices connected and I've told the AV software not to scan any of my music files.  But am I correct in understanding that you're advising me to disconnect from my home network (so as not to be able to access the internet)?
yes, that's right.  Just as a test.

Network drivers used to be able to make all sorts of things stutter when there was a lag. They'd get exclusive access to the CPU while trying to reconnect, or re-authenticate and nothing else could run.

Of course, I always hope (and hope and hope) that Windows got better about this, but it's trying for a couple of hours. :)


On some laptops there's actually a physical switch disabling networking.
Another thing to test is to make sure all your power saving options are off.
My computer is a Dell Inspiron 3847 desktop connected wirelessly to AT&T’s network. The Microsoft Windows Update came through 9/30/2016. All music is stored on the internal hard drive.
It looks like your computer probably has a 1 TB 7200 rpm mechanical hard drive. One thing that may be worth checking is the fragmentation status of the drive, and if Windows has been automatically defragmenting it on a scheduled basis.

Type "disk defragmenter" into the search box at the lower left corner of the screen, and then click "defragment and optimize drives," to open the defragmenter program that is built into Windows. Given especially that your computer has probably had at least two major Windows updates (from Windows 8 or 8.1 to Windows 10, and the Windows 10 Anniversary Update), as well as the usual updates that are issued each month, if the defragmenter program isn’t set to run on a scheduled basis the files on your hard drive could be highly fragmented (meaning that individual files would be broken up into many different physical locations on the drive), which could be contributing to the problem.

Also, it looks like your computer has both USB 3.0 and USB 2.0 ports. It might be worth trying whichever of them you haven’t been using to connect to the DAC.

Also, your computer was apparently offered with a choice of various amounts of RAM. If it has only the minimum 2 gB installed I would definitely suggest replacing or adding RAM to increase the total to at least 4 gB and preferably 8 gB.

-- Al

Great research, Al. My computer came with Windows 10 and has a 1 TB hard drive with 8 GB RAM . It defragments weekly so no problem there. I don't know which USB ports are 3.0 or 2.0. There are 6 USB ports on the back panel but the only things connected are the DAC & a wireless keyboard and mouse signal (thingy). There are 2 unused USB ports on the front. So far today, after suggested alterations, (thanks everyone) I've heard no drop outs. Will keep my fingers crossed.
Good!  The two bottom-most USB connectors on the rear are the USB 3.0 ports, and the four above it are the USB 2.0 ports.  See the diagram on the second page of this Quick Start Guide.

Good luck.  Regards,
-- Al
Hardwire up to your Dell

I would hardwire IF the modem/router box were in the same vicinity but it isn’t. It’s in the bedroom (closer to the home office) while my stereo equipment and computer are in the living room. Google Fiber comes Thursday, hopefully its signal is stronger.
The point is the Dell has all the music locally. The network is not being used for streaming, but there are still drop outs.


Still experiencing drop outs so I've given up. I'm listening to CD's on my computer's DVD RW drive and they sound great! Once Google is up and running I'll do more testing with the ripped FLAC files on JRiver and Signalyst HQ. If that proves a failure I might connect the computer to the bedroom modem by running an Ethernet cable down to and across the basement.
A simple way to determine if the wireless link has anything to do with the problem would be to see if dropouts still occur when the computer’s wireless adapter is disabled in Windows.

To do that right-click the start icon at the lower left of the screen and then select "Device Manager" in the menu that appears. In Device Manager expand the listings under "Network Adapters," then select (highlight in blue) the entry corresponding to the wifi adapter, and click the button at the top which says "disable" when it is pointed to. That button will look like a black downward pointing arrow at that time; when clicked it will change to an upward pointing green arrow that would allow you to re-enable wifi at a later time.

An entry will probably also appear under "Network Adapters" for the Bluetooth wireless function you are apparently using for your keyboard and mouse, as well as an entry corresponding to the wired Ethernet port (most likely referred to by some other name). Those should not be selected when you click "disable," of course.

Good luck. Regards,

Wednesday I disabled the wireless adapter and had no further dropouts. Thursday I enabled it (after Google Fiber was installed) & I've had no drop outs. Google's box transmits per coaxial and there's an ethernet connection on the rear of the box. If I experience future dropouts I will connect.