'New' power amp introduces ground loop hum - help?

My system:
TW cable box (HD) with HDMI connection to receiver
Sony BDP s5570 Blu Ray and SACD player conected to receiver
Pioneer VSX-1121-K receiver
Cambridge Audio ID100 dock connected to receiver via s/pdif

Front speakers: Martin Logan Ascent
SW: Martin Logan Dynamo 300
center and surrounds: Swans D 3.2

New component: Perreaux PMF 2150B power amp (200Wpc @ 8 ohm, 400Wpc @ 4 ohm).

Issue: As soon as I introduced the Perreaux to the system and powered it up, I got audible hum (like groud loop hum) from the Martin Logan Ascents, even when the Perreaux was the only component powered up.

I tried hooking the Perreaux up to a different power outlet, but no difference.

I'm looking for options / suggestions here. Is it the cable box like so may posts seem to suggest? And if so, will a Axiom Audio ground isolator do the job?
Or what about the ebtech:


Or is the problem strictly tied to the Perreaux? If so, what can I do here?

I added a ground lift adapter (one of those things that converts your 3 prong plug to a 2 prong) to the power amp and changed nothing else.

No noise. Deadly silent amp now.

So the next question is: how do I get the same effect in a safer way?

I welcome all feedback and suggestions.
Thank you for our help.
You have a difference of potential, voltage, between the CATV company's coax cable and the grounding system of your home.

Get one of these.....
Thanks, I found a similar product which did the same job: