Need suggestions for balanced equipment to Combat noise/hum


Issue: Hum and Noise from long 20 ft RCA cables between preamp and amp. Current equipment is single ended preventing me from using balanced connections

Current system> Modwright LS100, Wells Audio Innamorata, Auralic Vega, etc

Temp solution is to relocate equipment rack and amp to a new (unpreferred) location in the room enabling me to use “short” 1.5m RCA between preamp and amp.

Long Term Solution: Move to a fully balanced system to lower hum/noise floor and allowing me to move equipment back to preferred location in the room.

Ask: Suggestions for truly balanced amp and preamp. Budget is 8K for both (preowned), split anyway you like 4/4 5/3 etc. I seem to lean towards a tube preamp and solid-state power amp and am wondering if I would be happy with a tube pre with class D mono blocks (think Bel Canto, Merrill, Benchmark). The tube pre should have low output impedance (transformer coupled?) able to drive 20 ft XLR cables. If there is a solid-state preamp that fits the bill, I am open to it. I did demo the JC2 in my system and although it sounded very good it was a bit thin sounding. (Note my tubes are NOS RCA’s).

The other loaded question is will I be happy with a Class D amp after living with the Wells.

Thanks for reading and any suggestions
jimbones
Have you tried more heavily shielded interconnect cables?
You have a ground loop no need to change cables or gear yiu need a 30 cent cheater plug

We have a lot of experience here this occurs when you bridge two differebt ac locations by connecting gear plugged into two different electical sources

To  test get a long extention cord and plug it in ar the first location and run  to the second if the noise goes away u have verified a ground loop

Dave and troy
Audio intellect Nj




@Audiotroy, cheater plug did not work. I ended up putting all the equipment in the rack and using shorter RCA, Apparently there were 3 issues occurring simultaneously. 60 hz hum, micro-phonic tube and hiss. I fixed 2 of the 3. I will use headphones today to troubleshoot some more.
Post removed 
@Tvad, this is very interesting, however, the output of my Modwright is not truly balanced. They provide XLR connectors for convenience only. They jumper 2 wires internal to the preamp. Will this still work?

Post removed 
I saw an Agon ad today for Elac dac/pre and amp New in boxes for $3500. True balanced and a match between amp and pre
Enjoy The Music gave the dac/pre an award


hth
+1 cheater plug - easy and cheap to try, could well solve the problem

if you want balanced gear, ayre for solid state, audio research for tube gear

outstanding quality, support and of course, sound
Did u try the extension cord and get everythingg on the same circuit?
Every thing is on same circuit
You sound like a great user case for the Benchmark class "G" AHB2 amp and their preamp. This setup is well within your budget at about $6k for both depending on whether you get the phono or non-phono version preamp. You will certainly get absolutely zero noise and hum but the big question is whether you will like their transparent detailed sound and how they match up with your speakers.

Pro’s of this system is you get perfectly matched equipment and professional level balanced circuits.
FWIW,

a lot of non TRUE balanced kit has XLR I/Os, but they’re simply for convenience


hth
Yes, I have to be careful. I'm thinking RP7 or maybe used BAT vk23se? Bryston17.3?
I ran a 20 foot rca between MWI Ambrose One and KWA 150SE temporarily without issue.  I also used the same 20 foot cable between another pre and power without issue.  I think your problem lies elsewhere.
@gordon I believe the issue is the synergy between the Innamorata and LS100. They are both fine operating with other devices, but together not so good.  Upscale Audio has a page discussing tube preamp hiss and says it is often a combination of low preamp gain and low input sensitivity for the amp. I believe this could be the issue.